2011 Soul CRDI main engine wiring loom - Kia Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-12-2019, 09:20 AM Thread Starter
Newbie
 
Join Date: Jul 2018
Location: Northamptonshire UK
Posts: 3
Drives: Soul Echo 1.6 CRDI
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
2011 Soul CRDI main engine wiring loom

I have been experiencing various problems over the past 8 to 10 months with the car going in to limp mode. The initial fault code showed P0237 boost pressure sensor low circuit, changed sensor, still had same problem. A while later a second code appeared P2015 intake runner position sensor circuit low.
To cut a long story short I traced the fault to the main engine wiring loom having been resting hard against a bracket on the battery retaining bracket / ecu mount at the rear of the battery. The bracket had worn through the loom insulation then through some of the insulation of some of the wiring. This was then shorting to ground and causing the faults. It appears the loom should be clipped to this bracket, I believe this had not been fixed from new as apart from normal services no other work has been carried out, unless of course this was un-clipped by the garage at the time of a service.
I reported this to KIA customer services as it was a potential fire risk. I was appalled by their response, they showed no interest and expected me to pay to have a dealer just look at it.
I am posting this so people can check their own vehicles to be on the safe side. There is every possibility that mine is a one off but there is also that chance that there could be more.
I have attached pictures.
I would also appreciate feedback should anyone find the same problem.

Attached Thumbnails
Click image for larger version

Name:	IMG_20190311_163956_1552400316966.jpg
Views:	6
Size:	112.0 KB
ID:	104520   Click image for larger version

Name:	IMG_20190309_104051_1552400337827.jpg
Views:	6
Size:	67.1 KB
ID:	104522   Click image for larger version

Name:	IMG_20190309_104136_1552400359490.jpg
Views:	6
Size:	110.3 KB
ID:	104524   Click image for larger version

Name:	IMG_20190309_104154_1552400393145.jpg
Views:	7
Size:	131.2 KB
ID:	104526  
Stevehop is offline  
Reply

  Kia Forum > Regional > Europe > UK



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Kia Optima Engine Swap winelover15 4G (2011+) Optima 1 05-04-2018 09:18 PM
2014 Soul + Engine Replacement ssbabydaddy Kia Soul Forum 2 04-07-2018 01:39 PM
New User - Need information related to squirrels eating soy based wiring - Kia Rio hklayman01 2G (2006 - 2011) Rio & Rio5 8 02-21-2018 06:32 PM
CRDi engine 'hiccup' richs Kia Cee'd Forum 265 05-15-2011 09:50 AM
Engine stutters heavily when idle joebob 2G (1998 - 2001) Sephia 12 06-24-2007 03:17 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On