Kia Forum banner

1 - 16 of 16 Posts

·
Registered
2013 KIA Soul+ MT
Joined
·
25 Posts
Discussion Starter #1
Today was entirely frustrating, drove 4 hour round trip to purchase a Soul+ and when I got to the dealer I did a quick test drive. Before I even got out of first gear I right away noticed it was running a bit rough. Just enough to be annoying, kind of like what I experienced initially when testing a 1.6l base, which is why I moved up to a plus. I had test driven one previously and it was noticeably more smooth than the base, so when I went to buy one today I noticed right away something didn't quite feel right. I then drove another Soul+ on the lot to compare and sure enough that one drove more like I recalled. I ended up leaving without a Soul today because that was the last of the color I wanted. :(

Can anybody explain what might be going on? I really want to buy the car but could not stand that slight bit of extra harshness that seems to be coming from the engine. Hard to explain but the feel and sound/vibration of the vehicle is slightly harsher and it creates a kind of vibration that is subtle but harsher than it should be, just enough that it makes the overall feel of the car not as smooth as it should be, at least not as smooth as the other plus models I drove. It's a harshness more in the midrange or top end, not a low frequency thing. It might even be exhaust related rather than engine related but it's just hard to tell the actual source.

Is this just a "tolerance" thing of engine part manufacturing between various Souls that I'd be permanently stuck with, or would it improve over time, or is there any other simple checks/tests I could suggest to their tech to maybe inspect? There were no codes in the computer, no obvious sign of anything else. We checked oil level and tire pressure, looks fine.

Help, any insight tremendously appreciated. Not sure where to go next with this....
 

·
Registered
2012 Kia Soul +
Joined
·
34 Posts
The Souls tend to have random rough periods, I personally think it's from a bad tune in the computer, but since I can't get into the computer I can't find out for sure.

Drive the same car again and I bet it's smooth.
 

·
Registered
2013 KIA Soul+ MT
Joined
·
25 Posts
Discussion Starter #3
The Souls tend to have random rough periods, I personally think it's from a bad tune in the computer, but since I can't get into the computer I can't find out for sure.

Drive the same car again and I bet it's smooth.
I did, drove the car like a half dozen times throughout the day and it never changed behavior. But I too wondered if it was something related to the computer rather than a physical problem with the engine. This car will be gone any day now, they are flying off the lots around here so if I don't buy it then it will be months, if ever, that I find another similar configuration within 100 miles. :( But a worse scenario would be to purchase the car and then never having it run as smooth as I know the plus models can. I suggested re-setting the computer by disconnecting the battery terminal for a moment, but they didn't want to do that. Short of that, bad gas was the only other potential simple explanation that crossed my mind.
 

·
Registered
2012 Kia Soul +
Joined
·
34 Posts
Mine will do it randomly, and then be totally smooth again..well as smooth as mine gets with my SSD Engine Damper installed LOL
 

·
Registered
Joined
·
1 Posts
I have noticed vibration while sitting at traffic lights. it is slight but noticeable an this is on a 2013 with 1000 miles. I really hope that it doesn't get worse.
 

·
Registered
2012 Soul +
Joined
·
10 Posts
Rough Idle too...

My 2012 Soul + (14000 miles) does have a rough idle after driving for a while. I notice especially when I put into park. She just kinda shimmy's..And I have too noticed it at red lights. I reported it to the dealer at last oil change and they said everything was normal....:((( I will report again at next oil change..I just wish it would do it when I pull into the service department..
 

·
Registered
2012 Kia Soul+, Kia Sportage SX FWD
Joined
·
472 Posts
My 2012+ does it occasionally, and randomly. No worries, I am at 21K miles now, and it has always been random and occaional. Turn up the stereo! Nothin wrong!
 

·
Registered
Joined
·
1 Posts
We've been dealing with a rough idle after warm up in the shop. took us a little while to figure it out but we replaced the cam actuator solenoids and so far prob was taken care of. perhaps that is an area you should check out...
 

·
Registered
2013 Kia Soul 2U AT silver
Joined
·
35 Posts
Did you buy it?

I did, drove the car like a half dozen times throughout the day and it never changed behavior. But I too wondered if it was something related to the computer rather than a physical problem with the engine. This car will be gone any day now, they are flying off the lots around here so if I don't buy it then it will be months, if ever, that I find another similar configuration within 100 miles. :( But a worse scenario would be to purchase the car and then never having it run as smooth as I know the plus models can. I suggested re-setting the computer by disconnecting the battery terminal for a moment, but they didn't want to do that. Short of that, bad gas was the only other potential simple explanation that crossed my mind.
What model and colour?
Did you buy it!
Curious in Canada.

Cheers. GotSoul
 

·
Registered
2013 Soul Base, AT, Titanium and 2013 Sorento, 4 cyl, Blue
Joined
·
104 Posts
Just rolled over 24K miles Friday...no issues. But just realized most in this thread don't have the 1.6 base engine.
 

·
Registered
Joined
·
6 Posts
I have a 13- 2.0 engine and yep, it rears it's ugly head from time to time...I don't like, nor, get the vibration thing. I notice mostly if I put in neutral (i have automatic) at a looooong light I know will be long and the Soul won't roll back of course.....other then that it's all good :)
 

·
Registered
2012 Kia Soul+, Kia Sportage SX FWD
Joined
·
472 Posts
I now have 34K miles on my 2012 Soul+, and the occasional lumpy idle pops up randomly. I carefully observe and try to see if it is temperature related, fuel related (did I just refuel? from where? etc), Did I drive it hard? Did I power slide around the corner just before the stop? It still appears to be absolutely random, and never even comes close to stalling. It really has no effect on the car other than is able to be felt at that particular moment. I think the car is fine and we are all freaking out over nothing!
 
1 - 16 of 16 Posts
Top