Kia Forum banner

1 - 20 of 20 Posts

·
Registered
2009 Kia Rondo EX Prem 2.4 inline 4
Joined
·
28 Posts
Discussion Starter #1
I have a 2009 2.4L Rondo, recently had noticed a whining noise.. sort of like a turbine sound, above the natural sound of the engine. It occurs ALL the time, and increases in pitch as I depress the accelerator, in gear or not... there is no power loss, no electrical issues, no dimming of headlights.. I took it to my mechanic (not dealer) and used his mechanics stethoscope.. listened to what he thought might be it.. he heard grinding in the tensioner and idle pulleys... I mistakenly told the dealer when I took it these items. and they immediately replaced them (under warranty).. although, the sound is still there.. the service manager insisted its the alternator.. which to mind is a bit odd.. as alternators last a little longer than 2.5 yrs in my experience, and why so loud a noise out of a small bearing in the alternator (which I actually thought was bearingless).. anyhow, its there now, getting alternator replaced.. though I am suspecting it will not fix the problem.. after reviewing the web.. am suspecting AC compressor.. but perhaps someone here can steer me in a better direction..
Thanks...
J.:(
 

·
Registered
2008 Rondo LX - 2011 Forte EX
Joined
·
103 Posts
My guess is alternator because due to the pulley sizes it is spinning faster than the engine and about the only thing that could make such a noise. Water pump is also in the picture but I dont think thats it at all.

unless perhaps you are hearing the timing chain whirling round and round.

good luck with the situation.
 

·
Registered
2009 Kia Rondo EX Prem 2.4 inline 4
Joined
·
28 Posts
Discussion Starter #3
thanks Tony K, they ordered that now.. though i still have a sneaking suspicion it is the AC compressor clutch causing the sound..
 

·
Registered
2009 Kia Rondo EX Prem 2.4 inline 4
Joined
·
28 Posts
Discussion Starter #4
Fixed

FIXED, AC Compressor Clutch.. apparently adding some shims to it got rid of noise.. funny, I researched this and found this and issue on Rio5 and on Accent, both used same engine, so I told dealer this might be issue.. 1 month ago... they ignored me.. replaced pulleys, alternator .. and finally.. did what I suggested and voila.. fixed.

Thanks Tony for your response regardless.
 

·
Registered
2008 Rondo LX - 2011 Forte EX
Joined
·
103 Posts
Very glad 'THEY' heard it and didnt give up on your car problem, especially since they only seem to respond to check engine lights and there is no code for a noisy AC clutch.

Lets hope the noise stays away forever.

Thanks for the posting the resolution, i was wondering what the outcome was going to be.

Later
Tony
 

·
Registered
Joined
·
1 Posts
That is great info to know...We have been have a similar problem in our '09 and each time the dealership conveniently cannot find a problem...although the difference for us seems to be that we seem to only have the problem when the transmission is engaged,especially in gear and with the brakes on (at traffic lights, intersections etc...). As I am due for a service, I will definitely be mentioning this new found info to the morons in my service center. We have had nothing but problems with poor service and excuses.
 

·
Registered
2003 Kia Sorento EX, 2004 Kia Sorento LX
Joined
·
2 Posts
What/how did you do to add 'Shims' to the AC clutch/compressor to stop whining noise? [email protected]
Bumping because I'd like to konw the answer to this as well. I have an 03 Sorento that started making this whirring noise. Really what I want to know is whether this is a noise it makes because the AC's old, or because it's ready to die.
 

·
Registered
Joined
·
1 Posts
Same noise in Forte

Its driving me crazy.. I suspect the compressor but you would think if its off an not turning the noise would go away..
do they eventually go out with this issue?
 

·
Registered
2012 Rondo
Joined
·
1 Posts
Btthompson, did you get the issue resolved? I have a 2012 Rondo 2.4 litre 2wd and have had a whirring noise that appears to have something to do with the transmission. Same thing as yours. Started at about 10k kms, is more noticeable when the engine is under load (transmission in gear) at stop lights, inclines, etc., but each year gets more persistent and more noisy, particularly when the engine and drive train are warm. Have had it at the service department every year for three years. They tell me they have NEVER seen this problem before. Last year it was left for four weeks. This year it has been there for three weeks but without resolution. I see that 2006 Sorentos were recalled for whirring/whining in the transmission and it was found there was a misalignment of a gear on the main shaft in the transmission. My Kia service department poo-poos the idea that this may be the same problem--even though the Sorentos were also 2.4 litre and 2wd.
"the morons in my service center. We have had nothing but problems with poor service and excuses"-- I love this. You must live in the same place that I do!
 

·
Registered
2009 kia rondo
Joined
·
70 Posts
Btthompson, did you get the issue resolved? I have a 2012 Rondo 2.4 litre 2wd and have had a whirring noise that appears to have something to do with the transmission. Same thing as yours. Started at about 10k kms, is more noticeable when the engine is under load (transmission in gear) at stop lights, inclines, etc., but each year gets more persistent and more noisy, particularly when the engine and drive train are warm. Have had it at the service department every year for three years. They tell me they have NEVER seen this problem before. Last year it was left for four weeks. This year it has been there for three weeks but without resolution. I see that 2006 Sorentos were recalled for whirring/whining in the transmission and it was found there was a misalignment of a gear on the main shaft in the transmission. My Kia service department poo-poos the idea that this may be the same problem--even though the Sorentos were also 2.4 litre and 2wd.
"the morons in my service center. We have had nothing but problems with poor service and excuses"-- I love this. You must live in the same place that I do!
Power steering pump. Or the screen oon the power steering resovoir is clogged, common issue.

Sent from my SM-G930V using Tapatalk
 

·
Registered
Kia Rondo 09
Joined
·
2 Posts
Do I understand this correctly the whine could be caused by a clogged screen on the psp/power steering pump reservoir. I am changing out the psp and I am adding a in line magnetic filter but if that screen is clogged I may still have a whine. After most of my research, I'm not convinced it was the pump but we shall see. I'm replacing the serpentine belt the two idler pulleys and I have the belt tensioner which has my 17mm wrench wedged on it at the moment. If I mount the filter on the line that's on the bottom of the reservoir which direction should the flow point. 2.4l Kia rondo 09
 

·
Registered
2009 kia rondo
Joined
·
70 Posts
Do I understand this correctly the whine could be caused by a clogged screen on the psp/power steering pump reservoir. I am changing out the psp and I am adding a in line magnetic filter but if that screen is clogged I may still have a whine. After most of my research, I'm not convinced it was the pump but we shall see. I'm replacing the serpentine belt the two idler pulleys and I have the belt tensioner which has my 17mm wrench wedged on it at the moment. If I mount the filter on the line that's on the bottom of the reservoir which direction should the flow point. 2.4l Kia rondo 09
It is a service bulletin, flow is restricted and causes noise. However, before doing this repair, my ac pump seized up and I lost all functions off the serpentine belt, alternator, steering, etc, from the belt not turning. $1000 later, replacing the ac compressor eliminated the sound in my car.

Sent from my SM-G950U using Tapatalk
 

·
Registered
2008 Kia Rondo LX 2.7 6 cyl.
Joined
·
7 Posts
Fixed

FIXED, AC Compressor Clutch.. apparently adding some shims to it got rid of noise.. funny, I researched this and found this and issue on Rio5 and on Accent, both used same engine, so I told dealer this might be issue.. 1 month ago... they ignored me.. replaced pulleys, alternator .. and finally.. did what I suggested and voila.. fixed.

Thanks Tony for your response regardless.
My 08 Rondo 2.7 is doing the same thing. Can you tell me how you did those shims? I've spent nearly a grand on solutions that didn't work. New Alternator, serpintine belt, idler pulley, power steering pump, Now my mechanic is suggesting ac pulley bearing. my air still works fine but that noise is driving me nuts.
 

·
Registered
2009 kia rondo
Joined
·
70 Posts
My 08 Rondo 2.7 is doing the same thing. Can you tell me how you did those shims? I've spent nearly a grand on solutions that didn't work. New Alternator, serpintine belt, idler pulley, power steering pump, Now my mechanic is suggesting ac pulley bearing. my air still works fine but that noise is driving me nuts.
My 09 rondo always made that whirring sound until the ac seized up. Replaced that pump, and never heard it again.

The ac pulley is always spinning whether ac is turned on or not.

09 Rondo 4 cylinder lx - NJ
 

·
Registered
2013 Kia Rio Sedan Auto 1.6 Turbo
Joined
·
213 Posts
When I hear these symptoms my first thought is ensuring a clean, and tight connection to both battery post and the alternator plug. I have "fixed" several cars like this. Sometimes just dirty post, or loose battery connection. Just recently on an 05 cavalier, exact symptoms as the OP. But you live and learn, thanks for the update on how it was fixed.
 

·
Registered
2009 kia rondo
Joined
·
70 Posts
When I hear these symptoms my first thought is ensuring a clean, and tight connection to both battery post and the alternator plug. I have "fixed" several cars like this. Sometimes just dirty post, or loose battery connection. Just recently on an 05 cavalier, exact symptoms as the OP. But you live and learn, thanks for the update on how it was fixed.
Apparently on the rondo, it's the bearing going bad that causes the sound. Which means it's a pretty bad part. Mine started whirring around 50k miles until it seized around 100k. 50k is way to soon for a bearing to start failing.

09 Rondo 4 cylinder lx - NJ
 

·
Registered
2008 Kia Rondo LX 2.7 6 cyl.
Joined
·
7 Posts
My 09 rondo always made that whirring sound until the ac seized up. Replaced that pump, and never heard it again.

The ac pulley is always spinning whether ac is turned on or not.

09 Rondo 4 cylinder lx - NJ
My 09 rondo always made that whirring sound until the ac seized up. Replaced that pump, and never heard it again.

The ac pulley is always spinning whether ac is turned on or not.

09 Rondo 4 cylinder lx - NJ
I ordered a AC kit , Waited a week for it , and turned out to be the wrong part. This darn Pandemic is making it impossible to get parts in a timely manor. What happened when your AC seized? Did it cause any other damage?
 

·
Registered
2009 kia rondo
Joined
·
70 Posts
I ordered a AC kit , Waited a week for it , and turned out to be the wrong part. This darn Pandemic is making it impossible to get parts in a timely manor. What happened when your AC seized? Did it cause any other damage?
It was a year or two ago, so I don't remember perfectly, but the serpentine belt locked up to an extent. Since it suddenly had a pulley locked up, the belt suddenly had all of that friction. I believe everything with a pulley stopped working like the steering pump, alternator, e.t.c. all the lights came on and power steering, brakes everything was gone, so you knew you had to pull over.

In 7 years and 100k miles since I bought it used, it's had very few problems and has been a good car. But some things are a little too cheaply manufactured, like the ac, and fail prematurely in my opinion. Im lucky enough to fix a lot myself, otherwise it would get pricey over time. The blue book on mine is about $3,000.

09 Rondo 4 cylinder lx - NJ
 
1 - 20 of 20 Posts
Top