Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My brand new 2005 Sedona LX Anniversary Edition (5000 km) has a continously nagging problem that the dealer can't seem to fix after 4 visits. There is a "chugging" sound on the engine whenever I press the gas lightly while it is idling. The Service Manager himself heard this significant sound when he tried out another brand new Sedona on their lot. My van doesn't sound like a brand new vehicle but more like a 10 year old one that needs its engines changed. This could also be related (or the cause) to the poor acceleration problem I posted before.

They said they have replaced all the pulleys in the engine and my ac compressor, yet when they return it to me after each visit, the sound was still there - as if nothing was done! THIS IS SO FRUSTRATING. I suspect that they didn't replace anything. They just put the replaced parts in the job order. Although I didn't have to pay anything so far, I don't know how this will affect my warranty in the future.

I am not sure why they had to change the pulleys or the ac compressor. If there was nothing wrong with them, why did they have to change them? These parts were brand new!

Can anyone please tell me what is my last resort if the dealer says that they can't fix the problem? What can KIA itself do?

Any help is appreciated.
 

·
Registered
Sedona 2.9 crdi LE
Joined
·
245 Posts
Hi

Why would they replace pulleys for a chugging sound from the engine??

To me it sounds more like fuel or ecu related. have they had it on the diagnostics machine??

Sorry not much help, but I noticed your from Canada and I head over there tomorrow for 2 weeks vacation in the Toronto area.

Simon
 
1 - 2 of 2 Posts
Top