Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,041 Posts
Discussion Starter #1
For the last few months I've been getting the skid control and descent lights at various times but they go out usually after a stop and restart. Recently another symptom joined the fun - under the condition of a light-throttle acceleration, then letting off the gas and getting back on lightly, as in stop and go traffic, the trans seems to go into Neutral momentarily then has a hard shift. Then the two lights come on and stay on until the key is turned off. They don't come back on after the next start. At all other times everything is normal.
I know I'll have to take it in at some point. Just curious if anyone else has encountered this.
 

·
Registered
2012 Sorento LX, 2012 Sportage SX, 1989 Taurus SHO
Joined
·
289 Posts
I drive a 2012 SX model and so far (been luck) have not experienced what you are experiencing.
 

·
Registered
2011 Kia Sportage SX - Clear White
Joined
·
484 Posts
I have a 2011 and never experienced anything like that. I would get it into the dealer sooner than later.
 

·
Registered
2015 Sorento EX V6 AWD Ebony Black
Joined
·
1,153 Posts
Those symptoms sound like a faulty brake light switch. This issue has popped up on occasion on the Tucson, & Sportage forum, search these forums for more info.


I thought there was a recall on this, I know I read it somewhere? It was only certain models, & years, but IMO it is more widespread then this. I noticed it myself on my previous 2010 Tucson before it was totaled (not related) but symptoms were very mild & occasional, and went away each time. Also, it affected the shifting, where it wouldn't want to come out of park on occasion. There is a shift lock release button on the console by the shifter, but it never got bad enough for me to use it.

I haven't noticed any issues yet with my 2011 Sportage EX, but I am leary of it.

Here Saxman check this out:

http://www.kia-forums.com/3g-2011-sportage/72212-esc-dbc-lights-issue.html
 

·
Premium Member
2017 Kia Niro Touring w/Tech Pkg, Blue/Grey
Joined
·
2,051 Posts
Recall was for 2007-2010 Sportage among others.....
 

·
Registered
Joined
·
1,041 Posts
Discussion Starter #6
Those symptoms sound like a faulty brake light switch. This issue has popped up on occasion on the Tucson, & Sportage forum, search these forums for more info.


I thought there was a recall on this, I know I read it somewhere? It was only certain models, & years, but IMO it is more widespread then this. I noticed it myself on my previous 2010 Tucson before it was totaled (not related) but symptoms were very mild & occasional, and went away each time. Also, it affected the shifting, where it wouldn't want to come out of park on occasion. There is a shift lock release button on the console by the shifter, but it never got bad enough for me to use it.

I haven't noticed any issues yet with my 2011 Sportage EX, but I am leary of it.

Here Saxman check this out:

http://www.kia-forums.com/3g-2011-sportage/72212-esc-dbc-lights-issue.html
Thanks for posting - that reminded me it did stick in Park one day. I just mashed the brake harder and it let go. I had considered the brake switch before but that was before it also started the trans bit. But yes, I agree it is most likely the brake switch. There's obviously nothing really wrong with the car - it runs great, but that brake switch is tied in with a lot of systems/programs and can really stink up the works. I think I'll take it in this week.
 
1 - 6 of 6 Posts
Top