Kia Forum banner

1 - 14 of 14 Posts

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #1
Anyone else having situations where the UVO system can't see all the songs on a USB device? I've got a 32GB and 64GB usb stick with lots of MP3's. Sometimes, the UVO system gets into a state where it can only see a limited number of tracks on the device. For example, earlier today I was using my 64GB USB device and all the tracks appeared to be there and voice searches worked fine. In the afternoon, it could only see about 6 tracks (out of 10,000) on the device. When I got home, I checked the USB fob on my laptop and it can see/play all the songs. The USB fobs are formatted in FAT32 format. Directory tree is:

artist --> album --> tracks

Power cycling the head unit didn't help. Any suggestions?

Best,
 

·
Registered
2013 Sorento SX AWD
Joined
·
54 Posts
the "sometimes" part is what has me puzzled. my manual for the infinity system (not sure if the same will apply to the uvo system) says that it won't recognize the music on the mem stick if there are more than 6,000 files on it. i would assume that it wouldn't work each time though, not just sometimes. the other limit that it lists is no more than 2000 folders.
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #3
the "sometimes" part is what has me puzzled. my manual for the infinity system (not sure if the same will apply to the uvo system) says that it won't recognize the music on the mem stick if there are more than 6,000 files on it. i would assume that it wouldn't work each time though, not just sometimes. the other limit that it lists is no more than 2000 folders.
Yeah, I agree. It was working like a champ and now, it isn't. Just for grins, I'm going to reformat one of the USB fobs and try again. Actually, I miscounted...there's only 7,000 files and 1,250 folders.

Best,
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #4
I'm starting to think that I might just have a bad UVO unit. Now, it's occasionally unable to accurately do voice searches for albums/tracks/artists. I can manually get to songs using the touch screen, but saying "play artist Metallica" was getting me "playing USB artist Hall and Oates" (lol...which isn't even an artist that I've got on the USB media). I've got a bog standard American English accent so I'm a bit confused by this.

Best,
 

·
Registered
2013 Sorento LX V6, '03 GSX-R600, '00 Nissan Maxima SE
Joined
·
150 Posts
I'm starting to think that I might just have a bad UVO unit. Now, it's occasionally unable to accurately do voice searches for albums/tracks/artists. I can manually get to songs using the touch screen, but saying "play artist Metallica" was getting me "playing USB artist Hall and Oates" (lol...which isn't even an artist that I've got on the USB media). I've got a bog standard American English accent so I'm a bit confused by this.

Best,
I'm having issues also. Out of 600 or so songs, UVO only sees two. Voice search doesn't even work for me. I'll keep at it and see what I can make happen.
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #6
I may have found a solution. Initially I thought I might have a bad USB flash drive. It would work and then it wouldn't (see above). So I reverted to my other 64GB USB drive and that ALWAYS worked. Upon further inspection, the only difference between them was the partition format. The working one used "exfat" and the dodgy one was using "fat32". I reformatted the dodgy one using an exfat partition and now it works reliably and voice searches are also working again. I didn't see anything in the documentation about this.

Readers Digest version: Format your USB drives with "exfat" partitions instead of NTFS or fat32. If you don't know how, here's how:

How To Format A USB Drive & Why You Would Need To

Best,
 

·
Registered
2013 Sorento SX AWD
Joined
·
54 Posts
that's good info, thanks Sauron. if i have issues, i will try reformatting to exfat.
 

·
Registered
2012 Optima LX 6spd manual
Joined
·
2 Posts
I'm having the same problem with my 64GB usb fob. The system doesn't see all the songs. I've got about 7400 songs and it only sees 5000. I tried formatting it in exfat but it wouldn't read it at all after that. I thought it was the usb so I went and rehabbed it for another 64GB and it did the exact same thing. All the songs pay on the computer. I figured out that it's only reading 19.20GB of the fob. The manual doesn't say that there is a limit to how much it can read. Also whenever I turn on the car uvo starts reading the usb fob from song 1 instead of picking up where it last left off. It did it a couple of times them stopped doing it. Anyone having that issue too?
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #9
I'm having the same problem with my 64GB usb fob. The system doesn't see all the songs. I've got about 7400 songs and it only sees 5000. I tried formatting it in exfat but it wouldn't read it at all after that. I thought it was the usb so I went and rehabbed it for another 64GB and it did the exact same thing. All the songs pay on the computer. I figured out that it's only reading 19.20GB of the fob. The manual doesn't say that there is a limit to how much it can read. Also whenever I turn on the car uvo starts reading the usb fob from song 1 instead of picking up where it last left off. It did it a couple of times them stopped doing it. Anyone having that issue too?
Reformatting to exfat solved the "missing space" problem for me. Mine would also revert to the first track on the USB device, but that behavior changed when I upgraded my UVO to the newest firmware. Now it starts playing from wherever it left off. On my 64GB USB drive, I've got about 45GB worth of songs. On my 32GB, I've got about 31.5GB used.

Best,
 

·
Registered
2012 Optima LX 6spd manual
Joined
·
2 Posts
the last time i formatted to exfat i had the issue of the system not reading the usb fob. it was giving me a "Reading Error" message or something to that effect. i'll give it a try again. what allocation size did you use for your 64GB drive. where did you find the firmware update for your system? I looked on the website but couldn't find anything.
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #11
the last time i formatted to exfat i had the issue of the system not reading the usb fob. it was giving me a "Reading Error" message or something to that effect. i'll give it a try again. what allocation size did you use for your 64GB drive. where did you find the firmware update for your system? I looked on the website but couldn't find anything.
I chose "exfat" and "default" allocation size. I found the firmware by following the link in an articles posted here by someone else about upgrading the firmware. I included it in one of my recent posts if you want to search around for it. I've got the file here, but it's 11mb in size...probably too big to email you.

Best,
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
710 Posts
Discussion Starter #12
the last time i formatted to exfat i had the issue of the system not reading the usb fob. it was giving me a "Reading Error" message or something to that effect. i'll give it a try again. what allocation size did you use for your 64GB drive. where did you find the firmware update for your system? I looked on the website but couldn't find anything.
Sorry, I missed this reply. I just chose "default" for the allocation size. The UVO firmware is available on Kia's website once you register.

Best,
 

·
Registered
Joined
·
1 Posts
Make sure they are MP3s and not M4As. Anything ripped or purchased through iTunes will be an M4A unless you change your settings to MP3. I had the same problem with the UVO only playing certain songs even though I had many on the flash stick. Since then I converted a bunch to MP3 and now have a new problem.... the UVO freezes up when it tries to play anything. I'm not sure if it's the way they were converted (using iTunes) or if because they are from my Mac and not Windows pc. I'm not sure how many total files are on the stick so that could be the issue too?
 
1 - 14 of 14 Posts
Top