Kia Forum banner

1 - 20 of 25 Posts

·
Registered
2012 Kia Sorento EX
Joined
·
99 Posts
I just updated mine as well. I had looked into it months ago, but at the time the version number was pretty close to mine and there was no change log or anything to indicated what had been fixed, so I put it off. So far, I notice that the bug that prevented song titles from being displayed properly when using Bluetooth streaming is now fixed. I've always hated the fact that it will go out of shuffle mode when you turn off the car. Not sure if that's a bug or intended behavior, but we'll see if that's changed.

The other thing I would really like to see if they have changed is the delay that sometimes occurs between turning on the car and having the backup camera come on. Usually it's more or less instantaneous, but sometimes it seems that the system has to reboot and you're left sitting for a minute or so, which sucks.
 

·
Registered
2012 Kia Sorento EX FWD
Joined
·
9 Posts
I updated, and then i ran an errand. It was starting to have some issues on jumping to the next song over Bluetooth. Hopefully that doesn't continue.
 

·
Registered
14 Kia Sorento (V6 EX AWD), 2013 Nissan Altima SV
Joined
·
293 Posts
I just updated mine as well. I had looked into it months ago, but at the time the version number was pretty close to mine and there was no change log or anything to indicated what had been fixed, so I put it off. So far, I notice that the bug that prevented song titles from being displayed properly when using Bluetooth streaming is now fixed. I've always hated the fact that it will go out of shuffle mode when you turn off the car. Not sure if that's a bug or intended behavior, but we'll see if that's changed.

The other thing I would really like to see if they have changed is the delay that sometimes occurs between turning on the car and having the backup camera come on. Usually it's more or less instantaneous, but sometimes it seems that the system has to reboot and you're left sitting for a minute or so, which sucks.
Yes, I noted the same thing with my uvo. Sometimes it is slow to boot and other times the backup camera delays coming on or doesn't come on at all.
 

·
Registered
2013 LX GDI AWD
Joined
·
40 Posts
I can confirm that my 2013 Sorento LX was on firmware 8 and this is firmware 10...updated fine with the files I downloaded from the other thread, haven't noticed differences yet but I haven't thoroughly tested it.
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
707 Posts
Discussion Starter #7
I have tested this for a couple of days and it hasn't fixed my biggest gripe with UVO. Random bumps while driving cause an interruption in music playing from the USB port and switches the source to the radio. The next random bump will suddenly cause the USB device to be recognized/scanned and play the first track on the device.

I've tried a half dozen different USB fobs, my phone connected as a USB device, an Intel 60GB SSD connected with a SATA/USB adapter and they ALL suffer the same problem. I'm inclined at this stage to think that the USB jack is defective and not making constant contact with the plugged-in device when the unit is jarred by a bump.

Sigh...
 

·
Registered
Mazda RX-8, Saab 9-5, 2012 Sorento SX
Joined
·
44 Posts
Apologies for the ignorance. I'm under the impression that my 2012 SX with the navigation system does not use the UVO system, at all. Thus, no need to worry about upgrading firmware. True?
 

·
Registered
14 Forte SX Koupe,15 Soul EX,58 & 90 Rolls Royces,92 Mercedes 500SL
Joined
·
333 Posts
jsh1120,you are correct .you don't have UVO so no update for u:)
 

·
Registered
13 Sorento LX
Joined
·
42 Posts
Just did this update last night, thanks to the OP for posting it!
The update itself took about 15 minutes (including downloading, opening, copying to flashdrive, and finally installing in the car), but it went very smooth, no issues at all.

No idea what the upgrade includes, and haven't had time to test anything out yet.
 

·
Registered
Joined
·
6 Posts
I can confirm that my 2013 Sorento LX was on firmware 8 and this is firmware 10...updated fine with the files I downloaded from the other thread, haven't noticed differences yet but I haven't thoroughly tested it.
thanks, how do you find out what firmware you have? Sorry I am a newb
 

·
Registered
Joined
·
46 Posts
Just did this update last night, thanks to the OP for posting it!
The update itself took about 15 minutes (including downloading, opening, copying to flashdrive, and finally installing in the car), but it went very smooth, no issues at all.

No idea what the upgrade includes, and haven't had time to test anything out yet.
I tried 2x, it kept saying cannot read flash drive. I'll try a different drive.
 

·
Registered
2012 Kia Sorento EX
Joined
·
99 Posts
To respond to myself...

I've always hated the fact that it will go out of shuffle mode when you turn off the car. Not sure if that's a bug or intended behavior, but we'll see if that's changed.
Nope, not changed.

The other thing I would really like to see if they have changed is the delay that sometimes occurs between turning on the car and having the backup camera come on. Usually it's more or less instantaneous, but sometimes it seems that the system has to reboot and you're left sitting for a minute or so, which sucks.
If anything this might be worse than before. Hard to say.

By the way, what's the biggest USB memory device that people have successfully used with their UVO systems? I have a 32GB stick, but was wondering about getting a 64GB one.
 

·
Banned
2013 Sorento EX V6 AWD
Joined
·
707 Posts
Discussion Starter #20 (Edited)
By the way, what's the biggest USB memory device that people have successfully used with their UVO systems? I have a 32GB stick, but was wondering about getting a 64GB one.
I have a Patriot 64GB USB fob that works. However, it suffers from the same problem that I've reported in other threads...significant bumps cause it to "lose contact" with the head unit. The head unit then reverts to the radio until such time as it thinks the USB has returned. Then it will interrupt the radio, scan the USB drive, and begin playing from the USB from whatever it feels is the first track on the device. This is the same with multiple USB devices I've tried. FAIL Another "quality" Microsoft product, I'm afraid.
 
1 - 20 of 25 Posts
Top