Kia Forum banner
1 - 5 of 5 Posts

·
Registered
2008 Kia Rio
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi, I live in Germany and have a US Spec car. Don't speak German.

My key does not work, neither key works in the ignition.
Suggestion was immobilizer change.

Questions:
1. What part is the immobilizer? I can't find it.
What is it called if I'm looking for it on-line? I'll have to order it from the US and have it shipped.

Can anyone help at all?

Thanks.
 

·
Registered
2006 Kia Rio5
Joined
·
44 Posts
Not sure, but I believe I read that US Kias don't have an immobilizer? I have one in mine (Canadian) and it is located below the steering wheel behind the plastic panel. Looks like a small black square and it should have a part number on it.
 

·
Registered
2008 Kia Rio
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks, febrej.
Then I'm up a creek because my car just won't start, nada. Even with a new battery.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,959 Posts
chilegirl...
There are two different items that get confused when claiming "my car won't start".
1 The engine spins (turns over, cranks) but won't continue turning after releasing the key from the start back to the run position.
2 There is no movement of the engine (belts do not move when key is in the start position).. possibly a "click" but nothing more.
Which one do you have?
Was the car bought in the USA (not Canada)? If so there is no immobilizer on the car.
If the car cranks (engine moves the belts) you may have gas supply/ignition problems... If it (the engine) does not crank/turn over you may have a bad starter relay, a bad clutch safety switch (if the car has a manual transmission), a bad starter, or loose/bad connections on the wires from the (-)battery to the body/chassis/frame or the (+) to the starter...
Do you have ANY English speaking German friends that know anything about cars? The RIO is a pretty simple design car and we may be able to help you with some feedback from you.
ASK cobra259 (another moderator on this forum) in a private message (here) to see what market it was built for (USA/Canada). Give him the VIN# that is found in the bottom of the windshield on the drivers side of the car...This will tell if it is USA model.
Dave
 

·
Registered
2006 Kia Rio 1.4 16v dohc
Joined
·
110 Posts
When you turn on the car the code led turn on???
In this photo u can see it:

is the higher icon (a car with a key inside)
If it doesn't turn on when you turn the key, the code key is not recognized. I had this problem and, at my rio, was the antenna connector (the immobilizer antenna is the black circle around the ingnition pawl with the key positions printed on).

If both the key are not recognized, probably is the antenna. To solve it, i removed the coverage behind the steering and cleaned the antenna connector. If this not solve the problem u must try another antenna and, if work, change it (on italian kia reseller the price is around 30 euro). if with a new antenna and both keys u still have the problem is the immobilizer ecu broken, but I think it's really rare that the immobilizer ecu breaks.

In past i opened a thread about this problem on this forum: http://www.kia-forums.com/2g-2006-2010-rio-rio5/72874-kia-rio-2006-engine-immobilizer-problems.html

I hope I've helped you :)

PS: Sorry for my bad english
 
1 - 5 of 5 Posts
Top