Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Scenerio: 2 months ago, Check engine light came on. 2 error codes, something about a faulty something, and another one Torque Converter, it doesnt seem to have an issue at first, sometimes would hard shift. A month later, we noticed it would hesitate slightly when accelerating...and now? oy!! the dumb thing is a nightmare.

In the mornings, or after a long extended period of time (5+ hours) it wont budge. I put it in reverse, i feel it shift down, I hit the gas pedal..and NADA! it sits idle. revving up as in neutral. Reverse is worse then drive, but at any rate, it takes about 5 minutes to warm up and get going, after im on the road, it runs fine (and fine means that it goes without a HUGE issue, but hard shifts, delay shifs, and rolls back on hills just like a clutch would, needing me to hit the pedal hard to "shift" into gear)

any ideas? anybody else have this problem? is it really a Torque converter? or is my transmission shot?

and if thats the case....


does anybody know where i can get a New/used transmission at an affordable cost? because i am not paying the 1200 dollars they want around here.

ThanX.
 

·
Registered
Joined
·
14 Posts
Check out www.car-parts.com for a used transmission near you.


In the mornings, or after a long extended period of time (5+ hours) it wont budge. I put it in reverse, i feel it shift down, I hit the gas pedal..and NADA! it sits idle. revving up as in neutral. Reverse is worse then drive, but at any rate, it takes about 5 minutes to warm up and get going, after im on the road, it runs fine (and fine means that it goes without a HUGE issue, but hard shifts, delay shifs, and rolls back on hills just like a clutch would, needing me to hit the pedal hard to "shift" into gear)
Check the transmission fluid pan for leaks because a car will have those symptoms of the fluid is low.
 

·
Registered
Joined
·
562 Posts
Hello,

Years ago I was into Ford Capri's and I bought this auto' Capri as a non-starter from auction showing every sign you have discribed.

Everyone told me it was the torque converter and so blindly I bought a s/h converter ready to fit but it wasn't the converter, it needed a new clutch plate.

Sadly this does sound like your converter but I have to ask, you have checked your fluid?

There are the exceptions but in my experiance auto' transmisions are preaty bomb proof at least on UK vehicles.

By the way, what was the other faulty something?
Seacam
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
thank you for the response. The fluid is fine, its been full from the beginning...but both of you sound like this isnt a situation i might need a whole new transmisssion? that would be a relief...
 
1 - 5 of 5 Posts
Top