Kia Forum banner

1 - 10 of 10 Posts

·
Registered
2014 Kia Sorento SX V6 GDI
Joined
·
5 Posts
Discussion Starter #1
The side indictator and rear turnindicator stay on when the car is on all the time. I understand there isnt a relay, how do I fix this?
 

·
Registered
2014 Kia Sorento SX V6 AWD
Joined
·
33 Posts
. Modern vehicles don't have turn signal flashers anymore - they are computer controlled and the sound is electronically generated rather than being the click of the relay points in a standard flasher. Part of body control module. Might be some corrosion at bulb connections changes resistance and current flow to led / bulbs not enough voltage to change electronic sw state.
 

·
Registered
2015 kia sorento lx
Joined
·
3 Posts
This happened to me when my aftermarket trailer module went. My drivers side mirror signal would turn on when I wasn't using signal and go off when I was. no flashing, just always on.
 

·
Registered
2014 Kia Sorento SX V6 GDI
Joined
·
5 Posts
Discussion Starter #4
Thanks guys I will try and clean connection and maybe some dielectric grease. We will see if that helps. If not on to test the trailer wiring connections.
 

·
Registered
Sorento SX AWD 2015
Joined
·
538 Posts
Trailer still installed? And defective can cause this. If it has a dedicated fuse, pull its fuse, if its still a problem then remove the unit. Otherwise you likely have a bulb problem with an element cross shorting or such.
 

·
Registered
2014 Kia Sorento SX V6 GDI
Joined
·
5 Posts
Discussion Starter #6
I found a blown fuse, I replaced the fuse and it blew immediately. And now i dont have any running lights on drivers side.
 

·
Registered
2014 Kia Sorento SX V6 GDI
Joined
·
5 Posts
Discussion Starter #7
The fuse was part of the trailer lights, the fuse was directly at the positive post
 

·
Registered
2014 Kia Sorento SX V6 GDI
Joined
·
5 Posts
Discussion Starter #8
I figured it out guys! Thankyou for all the help. It was a defective trailer wiring kit. I think it all started with the ground wire being corroded. When I change the fuse i think it blew the power converter and that is when I lost all running lights driver side. I have removed the trailer wiring for now and will order a new one. Thanks again!
 

·
Registered
Sorento SX AWD 2015
Joined
·
538 Posts
Thats what I said in post #5, if the trailer kit was still installed. It would be the culprit 99% of the time. Depends on how they fail. Sometimes pulling their fuse resolves the problem otherwise disconnect it from the harness is needed. Surprising how many are failing now. Knowone ever mentions what make of converter they had fail thought which would be nice to know. Not to repeat buying poorly engineered ones!!!
 
1 - 10 of 10 Posts
Top