Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I had purchased my 2011 Sportage 6 speed manual last month and have been pretty much pleased with it. Both the owners manual and research on google says all 2011 Sportages are equipped with a trip computer. Both buttons are present on the dash but seem to do nothing. The top button feels dead when pushed. The bottom button feels like it is in working order, but does nothing. Anybody else have the same issue? Is it an easy fix or nah?

Thomas - Kansas City, MO.
2011 Kia Sportage Base 6 speed manual
 

·
Super Moderator
Joined
·
9,474 Posts
I had purchased my 2011 Sportage 6 speed manual last month and have been pretty much pleased with it. Both the owners manual and research on google says all 2011 Sportages are equipped with a trip computer. Both buttons are present on the dash but seem to do nothing. The top button feels dead when pushed. The bottom button feels like it is in working order, but does nothing. Anybody else have the same issue? Is it an easy fix or nah?

Thomas - Kansas City, MO.
2011 Kia Sportage Base 6 speed manual
Using the below link, please add location and vehicle (year & model) to your signature
With the recent forum platform change, the location and vehicle details in your profile no longer show in each post.

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/signature


https://www.kia-forums.com/threads/forum-rules.27240/
 
1 - 2 of 2 Posts
Top