Kia Forum banner

1 - 15 of 15 Posts

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #1
Hi all I had owned a kia spectra 2002 for over four years having transmission problems almost every year haha. Last Sunday with a car technician we drained and changed AFT. I took it out to test it but noticed that the car slipped twice during the trip, I though it was because the tranny was somehow absorbing the oil. The next day the car failed to engage any speed while climbing to the third floor of a parking building. It seems that it slips when is forced to climp after changing from 4th to 3rd. The technician said after testing that obd was throwing solenoids codes but Do you guys think this isn't actually a major problem other than electric issues? Have you ever faced a problem like this after an ATF change? We replaced the disc set of this one like 8 months ago and the only thing I complained was that the shifting was not that smooth but this slipping problem started to take the c# out of me cuz I'm concern that tranny needs to be replaced again. Any ideas? I'll bring the codes next week :D
 

·
Registered
1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Joined
·
2,847 Posts
I've faced that situation, every time I change the ATF on our "KiaStein" (a 2000 Sephia, similar to yours) and I could spend rivers of ink explaining the reasons; but I will use a shortcut insted: Pour a quart of Lucas "Transmission Fix" Additive, and be sure that the Transmission is filled properly.

You can find more Background information and the proper method to measure the ATF on these Automatic Kias; in the following link:

~► http://www.kia-forums.com/2g-1998-2001-sephia/76263-2000-sephia-blinkin-o-d-light-10.html

You can either read the entire thread, or only the last page (10) on the Link. Our transmission surpasses 225,000 Miles and our Kia was a Race car, which I received with several damages, its transmission even survived broken gears and differential, and still is going Strong on our extremely mountainous country.

Kind Regards.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,912 Posts
The very first thing that came to my mind is "what type of transmission fluid did he use?"....
The wrong type WILL cause the problems you posted and may damage the tranny...
Listen to Jes... He's our Sephia/early Spectra expert... and can solve most problems most mechanics can't...
Dave
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #5
That thread was actually how I found this forum, I stayed at night reading the whole thread, very interesting I felt better to know that there are many Spectras rolling over there.

I'll try to find Lucas transmission Fix down here in El Salvador. I not an expert at all but I assume I should drain some of the ATF (remove the a quarter of ATF) and refill (with a funnel) with Lucas transmission Fix, am I right?

Mine is over 124,000 ML in the ODO BTW.

I received the car from a friend when it had like 68,000 Miles on it. I have went through two tranny major works, 1st(2015): hard shifting and toasted, 2nd(Q1 2017): No traction at all (you set the lever to D-1-2-R and felt a little jump but no traction so toasted again), had to change a disk set. I have had no problems at all until I decided to change the ATF (with the help of a mechanic) he used Versatrans LV [Kendall synthetic blend.]

Update:

-I've started searching for Lucas transmission Fix without success, still trying.
-The car started to go normal (perhaps a air bubbles while pouring the ATF?), the only thing I've changed is the way I drive, less racing mode to avoid sudden changes like going from 2000 to 4000 rps.

I am new forum member BTW I'll try to contribute with my experiences learned while owning a Kia car for almost 5 years.
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #6
I was there when our mechanic poured the fresh ATF and I can surely say he did not do the five seconds wait you suggest at your post [ I can't quote it here because of my amount of post in the forum, I'm newbie :( ]

I will check the level myself to see because it looks he overfilled it.
 

·
Registered
1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Joined
·
2,847 Posts
... Listen to Jes... He's our Sephia/early Spectra expert... and can solve most problems most mechanics can't...
Dave
Thank you Dave, for your kind words, which I really appreciate.

... I will check the level myself to see because it looks he overfilled it.
Yes, check the level yourself by following the steps I wrote; and also I believe that the fluid used could be the Wrong one; your best bet is Valvoline's "MAXLIFE" ATF for high mileage vehicles; I am using it even in Newer cars, such as a Kia Sorento posted here on the Forums, without reaching the High Mileage, and is working Flawlessly.

Here in Honduras, you can easily find the Lucas Transmission Fix at the Local "Frenos NG" or thye Local "Napa" Stores, among others, but the El Salvadoran stores known as "Impressa" and "Super Repuestos" Might have Lucas Additives.

Good Luck, Kind Regards.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,912 Posts
I checked the applications for that fluid and it says it meets specs for SP type III (Diamond III) and SP type4... so it should not have caused problems within the transmission...

Here is a site that gives the correct ATF fluid specs...and the 2002 Sephia (Spectra) can use SPII or SPIII fluid...
Automatic Transmission Fluid | Street Smart Transmission

BTW... overfilling the transmission can also cause problems because the fluid will foam... Here's hoping you can get it running right...

P.S. I don't know your "native" language but your type English is quite good and welcome to kia-forums!
Dave
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #9
Thank you Dave, for your kind words, which I really appreciate.



Yes, check the level yourself by following the steps I wrote; and also I believe that the fluid used could be the Wrong one; your best bet is Valvoline's "MAXLIFE" ATF for high mileage vehicles; I am using it even in Newer cars, such as a Kia Sorento posted here on the Forums, without reaching the High Mileage, and is working Flawlessly.

Here in Honduras, you can easily find the Lucas Transmission Fix at the Local "Frenos NG" or thye Local "Napa" Stores, among others, but the El Salvadoran stores known as "Impressa" and "Super Repuestos" Might have Lucas Additives.

Good Luck, Kind Regards.

Hi,

I finally found Lucas Transmission Fix at NAPA, it does cost USD$25 I believe the price will worth it, something that's odd to me (because of the consistency of the additive) is that I am not suppose to drain any ATF out

Is says: 'This is because the blend of friction modifiers and other additives are supposed to dissolve into your existing transmission fluid while warm, so you don’t have to bother with draining any fluid out.'

So the correct process should be:

1-Start the Engine, wait for it to warm up while idle.
2-With a funnel, pour at least 12Oz of Lucas Transmission Fix.
3-Go for quick trip to test it out.

Will let you guys the results!
 

·
Registered
1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Joined
·
2,847 Posts
... I am not suppose to drain any ATF out ...
Yes, but Despite that, I always drain enough ATF and then Pour the ATF Adiitive, finally, after the test drive (Driving for a while on EACH gear position of the shifter), I top the ATF to its proper level with fresh fluid.

Don't forget to pour the Lucas ATF additive, with the engone ON at Ralenti, in "Neutral" Position.

Kind Regards.
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #11 (Edited)
OK.

First of all, GOD BLESS LUCAS OIL second, GOD BLESS You guys!

I finally bought Lucas Transmission Fix at NAPA, for ~$21 I checked the dipstick which, cleaned it


Then checked the level, surprise surprise, it was above the higher notch!


I used the hose and a syringe to drain some AFT, ~a quart of it. Then went for a quick trip to warm the engine up (still facing the weird behavior when downshifting, yuck!) With not much hope I poured 3/4 of Lucas Transmission Fix it took a while since the liquid is thick, however the slipping when downshifting was still happening :(

The behavior was completely corrected after pouring the full bottle, now the car is now running and shifting even better than before, pure magic!

So my suggestion to anyone trying this trick is to drain the excess warm the engine enough then pour the entire (1 Quart) of the additive with no fear, no need to be shy with it.

Again a Huge THANK you Loyale and DavesSpectra, ~un-be-lie-va-ble~ :D
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #12
Hi Guys,

False-Positive.

It started slipping again when down-shifting at high speeds, it improved a bit but I believe is a combination of issues.

Will have to rebuild tranny anyways.
 

·
Registered
1985 Subaru Loyale (wagon), 2000 Kia Sephia (sedan), and 1969 Mercury Comet (coupé)
Joined
·
2,847 Posts
Do you remember this post?

... I always drain enough ATF and then Pour the ATF Additive, finally, after the test drive (Driving for a while on EACH gear position of the shifter), I top the ATF to its proper level with fresh fluid...
So, it worth to re-check the ATF Level, again, after some miles with the Lucas Additive; because the Transmission might be overfilled...

Kind Regards.
 

·
Registered
Kia Spectra LS 2002
Joined
·
9 Posts
Discussion Starter #14
Hey guys, after a complete gearbox rebuild and check... the problem (although 50% less) is still ongoing, this is a nightmare. Solenoid was checked but perhaps this is an electrical issue.
 

Attachments

·
Registered
2002 optima
Joined
·
18 Posts
Same mechanic that has been involved with the other tranny fixes ?? Maybe time for a different 'mechanic' !!

Here in the states there is a new product from SeaFoam for transmissions too. $10 US

Did yo find out what tranny fluid the 'mechanic' used ?
 
1 - 15 of 15 Posts
Top