Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 01 Sephia Automatic :)( I only wish I had a manual)
Recently purchased @180K miles. It started slipping a little bit (I would press the gas, and it would take 1/2 a second or a little more to catch), and quickly got worse. Now it's at the point that in drive it does jack (from idle). I have to shift down into 1st to get it moving (which also has a second delay to catch), then 2nd, then drive. CE light of course came on, and when read said the transmission solenoids were going out. I check the fluid levels - very low. I added a mix of transmission fluid and lucas slip fix in hopes it would help (not fix...), but it just barely helped. So now I'm at the point of opening up the pan and completely flushing the fluid and replacing the filter. However, due to the burnt smell, I'm going to go ahead and assume that yes, the solenoid burned up. So question is - can I replace just the solenoid on this model, or do I need to replace the whole tranny? If the whole thing, I think it's time to junk it, except I haven't even gotten the title yet lol.

If you have any other thoughts on what I can check while I'm in there, let me know. I'll be working on it the next few days (I'm on paid vacation until Monday)
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,928 Posts
Read the "sticky" 2000 Sephia with ~►Blinkin' O/D Light ~....." on the top of the Sephia section...
Jeszek has a Sephia that was giving him problems with his automatic tranny...
This is a LONG thread but is worth your time...It may help you solve your tranny problems.
Dave
 
1 - 2 of 2 Posts
Top