Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Currently at 60k mileage. Trasnmission was smooth n no jerking. Last few weeks starting to have problem. Gear did not engaged when I shiftes to D. Had to try back n forth few times then ok. Last week car did not move when revved...loss of power n gear stucked at 4th. Service center said need to replace complete assembly!
Tranny oil clean n no signs of metal.chips.
Pls advice. I have a feeling it is not the transmission but rather other smaller parts ie sensor/cable link.etc.
Anyone had similar issue resolved pls.share.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,902 Posts
I found this in below thread
http://www.kia-forums.com/kia-mohave-borrego/51761-kia-borrego-transmission-problem-needs-replaced-2.html

"If we are talking about the 6 speed trans. behind the Tau V8. It is made by Sachs (ZF6) in Germany. It is a very good transmission. It is used in the BMW X5, and several models of Mercedes and Masaradis. There were some problems with the TCM on some early models of this transmission with stray electrostatic charges causing the transmission to do some weird things, but, they shielded the wiring to TCM and solved the problem.
This transmission is one of the reasons that I bought my Borrego.
kiadad"

If I were you I think I would be looking at wiring, connectors, and the TCM (transmission control module).... "If" the transmission is a Sachs (German) I would doubt that it is at fault...
Being in a hot area like yours might cause some wiring problems (cracked connectors or brittle wire insulation)...

There were problems with the "Asian" 6 speed also used in Borregos...
Dave
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Dave. I'll visit the garage n share this thought. Living in this part of the world leave me without much choices. Most mechanics would just recommend to replace complete set n make their life easy. Will inspect all cables, connectors. Any idea what to check for the TCM?

I'll try my luck if this work. Should I refill the tranny oil, start the engine n try if it works? or can it be done without the oil?

If it doesnt work, I guess I' ll have to source for a used tranny set n replace the complete set.
 

·
Registered
GSXR1000, Aprilia SXV550, Aprilia RSV4 Factory
Joined
·
146 Posts
The transmission used with the Borrego V6 is NOT the Sachs ZF6. It is built by Aisin, a Japanese company. They are usually pretty good transmissions. You can find them in Toyotas, Nissans & Hondas.
The Sachs ZF6 was only used by Kia/Hyundai in the Hyundai Genesis (with the Tau V8) and the Borrego (Tau) V8.
 
1 - 4 of 4 Posts
Top