Kia Forum banner

1 - 12 of 12 Posts

·
Registered
2012 Rondo
Joined
·
4 Posts
Discussion Starter #1
I am so frustrated! I just purchased the 2012 Rondo about a month ago and have loved the car EXCEPT...

I have an android Galaxy SII and it pairs fine but when it's paired and I'm listening to the radio it flips into BT Handsfree mode any time I touch my phone's screen. After a few seconds it flips back to the radio but if I touch the screen again - it flips. The dealer has replaced the unit but it's still happening and he deems that it's my phone. Well I went to Best Buy to look at an after market and paired with at least 6 different phones - cheap ones too - and no problems. We mimicked the situation in my car and there were no issues. I've looked for settings on my phone to change and nothing. I'm so frustrated as handsfree calling was a MUST HAVE when purchasing my car.

I was also frustrated to see no phone steering wheel mounted controls but that's my own oversight...

I've also read about others frustration with the steering wheel audio controls. Mine only scans too...this is terrible and I have NEVER seen this in a car before. It defeats the purpose of hands free!!! Plus - the manual for that stereo says it should jump to preset upon faster touch and will scan when held down...the way ALL others work - and should work.

I've also got the drivers side wind noise when driving at highway speeds. Haven't brought that to their attention yet as I only just noticed it - hopefully they can fix it.

In the end I am extremely disappointed with KIA and this vehicle in particular. My husband has a Forte and has had no problems (and I have no problems with my phone and HIS stereo - but it's a better unit). The sales guy admitted that the stereo was crap but they refuse to help this situation. Now I haven't pushed a ton because I've been trying to find out if it IS my phone but I did a factory reset last night and the same thing happens.

I've combed forum and forum and haven't found anyone else with this first issue. Anyone? Anyone have a solution?

Also - anyone have any success pushing to get the preset/scan buttons fixed? To me this should be a no brainer.

Help!!! I want to love this car but right now I am totally regretting this purchase as 2 of my main "must haves" in a car aren't even working.
 

·
Registered
former owner of a 2016 Soul SX 2.0L - Caribbean Blue
Joined
·
8,532 Posts
can't help you will your problems, but owned a Rondo for four years - great vehicle and extremely reliable. Sounds like you need to sit down with your service manager in your vehicle and go through with them as to what is happening. It's all covered under warranty and the only way they will know exactly what is happening.

I just have a normal cell phone with no Bluetooth so don't get involved in hands-free calls.

It would help also if you could fill out your LOCATION and DRIVES profile. I am guessing your are from Canada, but they do sell under the Rondo names in other countries too.
 

·
Registered
2010 Subaru Impreza 2.5i Premium 5-door, *old* 2009 Kia Rondo LX 4cyl 2.4L
Joined
·
492 Posts
My hands-free involves a bluetooth headset and a "dumbphone" that has bluetooth. Hasn't failed me yet and doesn't have any affect on my opinion of the vehicle.
 

·
Registered
2012 Rondo
Joined
·
4 Posts
Discussion Starter #4
Thanks revs but that does not help at all so why reply. I purchased this vehicle assuming certain features will work...go figure...and I'm right to want what I paid for.

Really hoping someone has some ideas....
 

·
Registered
2010 Subaru Impreza 2.5i Premium 5-door, *old* 2009 Kia Rondo LX 4cyl 2.4L
Joined
·
492 Posts
Thanks revs but that does not help at all so why reply. I purchased this vehicle assuming certain features will work...go figure...and I'm right to want what I paid for.

Really hoping someone has some ideas....
Geez, don't get a burr under yer mountie saddle.

Why don't you try a good aftermarket radio. Will improve sound quality a lot in the first place, and you might actually get bluetooth that works better with your model of phone.
 

·
Registered
07 rondo ex-v6 7seat, leather,sunroof.infinity 10 spkr audio,09 honda fit sport 5sp.
Joined
·
125 Posts
Geez, don't get a burr under yer mountie saddle.

Why don't you try a good aftermarket radio. Will improve sound quality a lot in the first place, and you might actually get bluetooth that works better with your model of phone.
Why should she???????? She just bought A BRAND NEW VEHICLE.
 

·
Registered
2007 KIA Carens 2l CRDi Automatic LS. KIA Picanto 1.1 LX
Joined
·
229 Posts
Hi cnye.

I have had a few problems that my local KIA did not want or could not fix , in the end I went to another KIA dealer and still do, its quite a long way away in English terms, 45 mins there and the same back again at 65mph. But the second dealer is a bit better.
Can you try a different approach with a different dealer or are you stuck with this one cos you bought from them?

Best of luck.
 

·
Registered
2010 Subaru Impreza 2.5i Premium 5-door, *old* 2009 Kia Rondo LX 4cyl 2.4L
Joined
·
492 Posts
Why should she???????? She just bought A BRAND NEW VEHICLE.People from texas just DONT GET IT.DUH!!!!!!!!!!:eek::eek::eek::eek:
If the dealer has already replaced the head unit, there's not much more they can do. Audio equipment is covered up to 30,000 miles. However, if even replacing the head unit didn't fix the "problem", you might try looking at other solutions (phone used, rom loaded on phone, etc), instead of yelling that the car is bad.
 

·
Registered
2010 Rondo EX V6 5 passenger
Joined
·
223 Posts
cnye, you could try your phone with another 2012 Rondo at your dealer. I have zero experience with BT but I know electronics can cause all kinds of headaches and are sometimes hard to reproduce. Could be compatibility issues. My neighbour had a hard time with her phone and brand new 2011 Elantra last year but not sure if problem was the same as yours; last I heard no one knew if it was the phone or the car causing the problem. Good luck.
 

·
Super Moderator
2008 SpectraSX, 2014 Optima LX,2006 Jeep Liberty, Linux Mint Mate
Joined
·
6,961 Posts
I agree with Freedom55...
The variables are too many... Samsung has their programmers and KIAs radio suppliers have theirs... They CAN'T foresee conflicts between all BT phones and car stereo units and It's impossible to expect them to solve it... Have you tried another smart BT phone in your Rondo to see if the problem still exists?
Sometimes one or the other will have to be replaced...or ... if you are lucky the programmers will release an update (to either item) to address a specific problem.
Dave
 

·
Registered
2012 Rondo
Joined
·
4 Posts
Discussion Starter #12
Thanks for the replies. Still frustrated. My husband is going to try his luck with the dealer as we BOTH bought and service our cars with them. He's a little more persuasive. It's just annoying to have something that's supposed to work not work. Again - I have paired with a bunch of other stereos in stores and have had no problem. My blackberry works although it flips to "Calling" and then "disconnect (or whatever it says) right after making a call...flipping it from radio to call mode briefly.

Anyone had success fighting for the steering wheel preset/scan issue?
 
1 - 12 of 12 Posts
Top