Kia Forum banner

1 - 10 of 10 Posts

·
Registered
2017 Kia Sorento
Joined
·
13 Posts
Discussion Starter #1
Hi all I have a 2014 Sorento and all the Buttons on the steering wheel seem to be messing up.
The vol up button turns the radio down, the vol down button is now the say command button,
cruise is working fine, the say command button does nothing. Any Ideas would be a great help.
ty
 

·
Registered
2017 Kia Sorento
Joined
·
13 Posts
Discussion Starter #3
I did install a brake controler and also programed the locks to open with one push of the drivers door handle but I am sure everything was working after that
 

·
Registered
'98 Silverado (farm truck), '11 Sorento LX-AWD (was mine now SWMBO's), '15 Sorento EX-V6
Joined
·
85 Posts
This happened a few times to me in my '11 Sorento - and once in my '15 - but every time after restarting the car everything had gone back to normal. Actually in the '11 hitting "reset" several times on the cruise control section always cleared it up. When it happened the one time on the '15 I was actually almost at work pulling into the parking lot so I didn't bother fiddling I just used the radio faceplate to change the station (I like to leave it on a certain preset for after work). When I got back in all was well. I've always figured this is just a software glitch in the CANbus to/on the steering wheel - that somehow the addresses on the device get bumped somehow and the chassis controller reads them and thinks it's getting commands to do one thing and it's actually another. I do a lot of CANbus development at work for industrial control systems and we've occasionally had weird glitches with sensor devices over-writing other sensors on the bus - seems to be the nature of the beast when you're working with devices made by 20 different mfg's.
 

·
Registered
2017 Kia Sorento
Joined
·
13 Posts
Discussion Starter #5
Ty all for your input. Not really sure what was happening here but we used it the way it was as we were out of town for the week. We came home Monday night was getting ready too take it to the dealer Tuesday and every thing was working again.
 

·
Registered
2011 Kia Sorrento & 2010 Kia Sedona
Joined
·
2 Posts
I bought a used 2011 sorrento and for the first year and half, these buttons all worked fine. Now sometimes when i start the car, they work and sometimes the functions behind the buttons are all mixed up. The volume up promps me to connect my iphone, the mode button will turn down the volume. And its not consistently the same. Other times i turn the car on they are all different. so once you get the hang of where the new functions are, they change. Any way to reset this myself or do i need to take it to the dealer?
 

·
Registered
2014 Kia Sorento SX V6 AWD
Joined
·
45 Posts
More than likely the horn ring is not making good contact. There is a spring that pushes this ring and over time the spring weakens. The ring provides ground for all the functions so unless you are knowlegable and mechanically sound bring it to dealer.
 

·
Registered
2011 Kia Sorrento & 2010 Kia Sedona
Joined
·
2 Posts
More than likely the horn ring is not making good contact. There is a spring that pushes this ring and over time the spring weakens. The ring provides ground for all the functions so unless you are knowlegable and mechanically sound bring it to dealer.
Thanks, i'll make an appointment to get it looked at.
 

·
Registered
Sorento SX FWD 2015
Joined
·
289 Posts
Here is a another thread with steering wheel button problems. It may give you more info.
 

·
Registered
2014 Sorento SX AWD
Joined
·
112 Posts
Happened to me. They replaced the clock spring which sort of fixed the issue. When it returned, they replaced the steering wheel controls. Been fine for a year.
 
1 - 10 of 10 Posts
Top