Kia Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2001 Kia Rio. Recently I have been having startup problems. I have changed the plugs and the air filter. No change. I then had the Mass Air Flow Sensor changed. It improved for a couple of days. Now I am having difficulty again. When I turn the key now, I don't even hear the fuel pump. Anyone have any ideas?
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,063 Posts
Well if you do not hear the fuel pump you might need a new one.... That would cause no start. maybe just to keep it cheap at first check all the connections going into the pump. Its located under the back seat. also check the fuse in the engine compartment could be blown!



 

·
Registered
Joined
·
18 Posts
My 2003 Rio has the same starting problems as yours. Understand from the experts. there is no compression form the cylinder heads when engine is cold.
My local agent change the entire cylinder heads, pcv value, fuel pump and now,
my car is ok.
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,063 Posts
if there was no compression the car would not start. I think your dealer is taking you for a ride my friend.
I hope you havent taken a dime outta pocket for what they have replaced in your car. from what you stated they replaced all this because the car stalls sometimes. you said in your otehr thread that it still wasnt fixed? here you say all is ok?????



 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top