Kia Forum banner

1 - 5 of 5 Posts

·
Registered
2006 Kia Sorento,AutoTrans,P/T4x4
Joined
·
8 Posts
Discussion Starter #1
Just changed my original battery with a exide 750 cca battery. once I started it the engine revs up for 5 seconds then idles normaly Tried it about a dozen times with the same outcome. any ideas?
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,483 Posts
How much is "up" ??
 

·
Registered
Joined
·
35 Posts
1500 rpms on dash tach
After disconnecting the battery for any length of time, the ECU resets and has to "relearn" the idle again. When I did my timing belt I disconnected my battery and when I started it back up again I freaked out and almost shut it off thinking I did something wrong, lol.

Do you keep disconnecting the battery when it does this or does it do it all the time since you put the new battery in?
 

·
Registered
2006 Kia Sorento 3.5 5sp Auto
Joined
·
267 Posts
I read somewhere that when the battery is disconnected these newer cars need to idle for about 15 minutes while they go through checking sensors and stuff like that.
And they may rev a little high, but just let it idle and should go back to normal after some period of time.
You should also open and close all windows and sunroof so they re-learn their end point or something like that.

I had a look at the ford re-initialization test and it goes for about 30 minutes.
First stage is idling, second stage driving up to 60 kms//hr and 3rd stage driving up to 90km/h
 
1 - 5 of 5 Posts
Top