Kia Forum banner
1 - 2 of 2 Posts

·
Registered
2000 Sportage A/T 4X4
Joined
·
68 Posts
Discussion Starter · #1 ·
It's been two days now that my sporty stalls at idle, most especially in long traffic. Can't check it with a scanner because it has the odb1 under the hood, so I just shorted the "test" and "gnd" and it gave me eight quick flashes. Eight quick flashes corresponds to the MAF, so I removed and cleaned with carb cleaner the MAF and added the IAC while at it. Disconnected the battery for a minute or two to reset the ECU then I replaced the air filter and reinstalled the MAF and IAC . Started the engine, waited for normal engine temp then roamed a bit, didn't stall at first, waiting for the green light at signal then suddenly the check engine light lit then engine rumbles and died but it started up easily when I turned the key. Checked again the flashes and still gave me eight quick flashes, so I just bought and installed a new MAF after reseting the ECU. Drove a bit for few miles then I thought it was OK but I stopped at the signal near my house, check engine light lit and engine rumbles then died again. It just stalls at idle but the performance is great and engine always starts quickly. Hope you guys could help with this, thanks!!!
 

·
Premium Member
1999 Sportage A/T 4WD
Joined
·
987 Posts
When it stalls connect the terminals 1 and 5 of the diagnosis connector (the one that you say it is OBD1, but it is OBD2) with a jumper wire; if it stops stalling then replace the fuel pump relay.
 
1 - 2 of 2 Posts
Top