Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
When I turn to the right, I hear a squeaking sound. I was at the dealer for some recalls and he said the boot was dried out and they lubed it. It was good for a day and started to squeak again. Does anyone know where this rubber boot is? I can lube of myself as I have some great stuff for that.
 

·
Registered
White 2012 SX AWD
Joined
·
802 Posts
I get something that may be a squeak but I only get it at the far left or far right when turning. Usually backing up and I think it happened when the AC was on. I think there was another post about it. Have to find it. Something about the oil level or some air or something.

However, if yours is like mine, I don't know what the dealer is referring to. I don't think that's the issue.

Please provide more details about when it happens...oh, and please file out model and location in your profile.

Tanx
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #3 ·
It happens when I turn to the far right and I can hear it at the wheel. It sounds like two pieces of thin styrofoam rubbing together. It goes away the more I turn it which is why I believe they say its a rubber boot. Ill check the fluid levels though, you never know.
 

·
Registered
2012 Kia Sorento
Joined
·
1 Posts
Under the dash, under the steering wheel, behind the break peddle is steering linkage leading through the boot you are looking for. My boot looks like it is two pieces, a small upper and a larger lower. If you follow the steering shaft up toward behind the dash, there is a linkage joint which may also need grease.
let me know how you solved the problem because I may need the remedy also. 863-289-9514
 

·
Registered
White 2012 SX AWD
Joined
·
802 Posts
I believe the thing that finally corrected this was the steering rack was replaced.

FYI, my dealer did try lubricating the "boot" or rubber yoke under the steering column under the dash, etc... which did not fix the issue.

I believe another user on this forum had the same issue and the same resolution.

When I had discussed the issue with the mechanic it sounded like he had made the same repair before for this issue.
 
1 - 5 of 5 Posts
Top