Kia Forum banner
1 - 20 of 137 Posts

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #1 ·
Hello All,

Vehicle: 2021 Sorento SX

I've had vehicle for only 2 months and 1 day. So far I'm enjoying my vehicle EXCEPT for this issue I've experienced twice since ownership (once last month Feb and yesterday 23 March).

Scenario: In traffic at a stop either needing to make a turn or just accelerate forward. Accelerator does not respond to the pressure being applied and the vehicle barely moves even with pedal nearly to the floor (like crawls 1-2MPH) to get across the intersection and then it suddenly performs as if nothing happened. This is very dangerous as the vehicle is almost practically stalled and all you can see is oncoming traffic approaching... Wondering if perhaps the engine auto-shut off at stop gets confused or drive by wire technology / sensor for this vehicle is funky?

Not sure if anyone has experienced this. Unfortunately, not a simple issue to replicate and unsure of the methods for scanning and obtaining diagnostics.

Dealer hasn't heard of the issue yet, so I'll have to take it in, but thinking this could pop up on other vehicles. Very scary and very dangerous.

Cheers
 

·
Registered
2021 Kia Sorento SX X-Line in Sparking Silver and 2019 Hyundai Tucson Sport in White
Joined
·
95 Posts
I had a similar issue with 2016 Tucson. It has a 1.6 turbo engine. They ended up having a recall for an acceleration sensor. I dealt with it for 6 months until the recall was sent out. I would floor it and the engine would rev, literally red line but the car wouldn't move. It happend a few times when getting on to the highway and that wasn't safe. They said it was because the car was shifting to a lower gear and then I try to accelerate and the cars sensor would not go off and still make the engine think I was still slowing down. Idk how accurate that is because I'm not mechanic lol but that was what I was told and them the sensor was replaced and never had that issue for the rest of my lease.
 

·
Registered
Kia Sorento SX Prestige 2021
Joined
·
133 Posts
I’ve posted about having this same experience in the quibbles thread! Someone acted like I didn’t know about the auto stop feature or that I don’t know how to drive the car. It’s not the auto stop feature since I disable that cause I hate it. And I’ve never experienced this in any other vehicle. There is an issue with the transmission. I’ve experienced this at least 3 times since ownership.
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #4 ·
I’ve posted about having this same experience in the quibbles thread! Someone acted like I didn’t know about the auto stop feature or that I don’t know how to drive the car. It’s not the auto stop feature since I disable that cause I hate it. And I’ve never experienced this in any other vehicle. There is an issue with the transmission. I’ve experienced this at least 3 times since ownership.
Thank you so very much for posting. I too hate the auto stop feature, but I don't always switch it off. I wish there were an option to have it off unless requested.

I've reviewed my drive logs on UVO (that is actually somewhat helpful) and it seems the stalling/crawling from a stop issue is occurring almost monthly within + 2-3 days. So... next month if I'm correct, it should happen around this time again. I'll probably try to get into the dealer then, but I dislike that they may rack up miles on it trying to replicate the issue.
 

·
Registered
Kia Sorento SX Prestige 2021
Joined
·
133 Posts
hmmm you may be on to something! I’ve experienced it 3 times & i’ve owned the car since the end of Dec. So it appears it’s 1/month lol. I don’t remember the exact timing, i just know it occurred. Maybe i’ll pay attention as to when it happens the next time it happens.
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #6 ·
I had a similar issue with 2016 Tucson. It has a 1.6 turbo engine. They ended up having a recall for an acceleration sensor. I dealt with it for 6 months until the recall was sent out. I would floor it and the engine would rev, literally red line but the car wouldn't move. It happend a few times when getting on to the highway and that wasn't safe. They said it was because the car was shifting to a lower gear and then I try to accelerate and the cars sensor would not go off and still make the engine think I was still slowing down. Idk how accurate that is because I'm not mechanic lol but that was what I was told and them the sensor was replaced and never had that issue for the rest of my lease.
Yes - this is exactly the symptom only when I rev, nothing - well i hadn't actually looked at the RPM gauge, but no audible revving. There's no response - just a crawl.

I had a similar issue on my VW years ago, but that was a bad performance flash. The car would just lose acceleration while driving, and I had to do a quick off/on of the ignition to get it going again.
 

·
Registered
2021 Kia Sorento SX X-Line in Sparking Silver and 2019 Hyundai Tucson Sport in White
Joined
·
95 Posts
hmmm you may be on to something! I’ve experienced it 3 times & i’ve owned the car since the end of Dec. So it appears it’s 1/month lol. I don’t remember the exact timing, i just know it occurred. Maybe i’ll pay attention as to when it happens the next time it happens.
Sometimes the mechanics might drive it and add miles to it but never find the issue. I had an issue with my 2019 Tucson and I took it to the dealership 3 times. All three times the managers drove it home and back and never found the issue. Sometimes the car would not turn on. It's crazy that I had a 1 month old car and it wouldn't turn on. They never had the issues and one day I had to call put of work because I was unable to turn it on. I had it towed to the dealership because nothing was working. But when it got to the dealership it turned on like nothing happened. Then one day I had the issue and I recorded it on video, then the next day on my way to the dealership after work it did the same thing and I recorded that too. On the 4th time I took it to the dealership I told them I I taking the car back home if they didn't find the issue. They contacted mechanics at the Hyundai home office (or wherever the experts on the car worked) and they told them to check one stupid cable and BAM! The wire was not making contact and the replaced it and the car never had any issue again. They paid me back for the tow, rental and the dealership gave me a check for my next month's payment. They would have had to take the car back if they didn't fix it. Moral of the story, record what happened so they are forced to figure out the issue rather than plug something into the obd and tell you nothing is wrong. Also, invest in a dash cam so if you are trying to accelerate and the car won't go, you can show them the video right on the spot.
 

·
Registered
2021 Kia Sorento SX X-Line in Sparking Silver and 2019 Hyundai Tucson Sport in White
Joined
·
95 Posts
Yes - this is exactly the symptom only when I rev, nothing - well i hadn't actually looked at the RPM gauge, but no audible revving. There's no response - just a crawl.

I had a similar issue on my VW years ago, but that was a bad performance flash. The car would just lose acceleration while driving, and I had to do a quick off/on of the ignition to get it going again.
There was very loud revving on my part when that happened lol I never got that on video but a lot of people complained and it ended up being a huge issue. My 2016 tucson had 11 recalls. I'm glad my lease ended when it did. I mentioned it in post below, try your hardest to get that on video. A dual camera dash cam could help. If they see you trying to accelerate and the the car not moving, that would force them to dig a little deeper into what the issue might be. It's not safe, especially since this car is a little bigger than most crossover SUVs.
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #9 ·
Sometimes the mechanics might drive it and add miles to it but never find the issue. I had an issue with my 2019 Tucson and I took it to the dealership 3 times. All three times the managers drove it home and back and never found the issue. Sometimes the car would not turn on. It's crazy that I had a 1 month old car and it wouldn't turn on. They never had the issues and one day I had to call put of work because I was unable to turn it on. I had it towed to the dealership because nothing was working. But when it got to the dealership it turned on like nothing happened. Then one day I had the issue and I recorded it on video, then the next day on my way to the dealership after work it did the same thing and I recorded that too. On the 4th time I took it to the dealership I told them I I taking the car back home if they didn't find the issue. They contacted mechanics at the Hyundai home office (or wherever the experts on the car worked) and they told them to check one stupid cable and BAM! The wire was not making contact and the replaced it and the car never had any issue again. They paid me back for the tow, rental and the dealership gave me a check for my next month's payment. They would have had to take the car back if they didn't fix it. Moral of the story, record what happened so they are forced to figure out the issue rather than plug something into the obd and tell you nothing is wrong. Also, invest in a dash cam so if you are trying to accelerate and the car won't go, you can show them the video right on the spot.
Good idea. I have a dash cam, just need to install it. I'm sure if I have the camera in place and the issue occurs, it will be an expletive laden recording!!
I just hope that when it happens again there's not a lot of traffic. That is the scary part - it has happened now twice in traffic and literally crawling across traffic when you have a gap to make a turn is frightening.

Worse case, when I take it in, I'll point them to this post so that they'll know I'm not crazy.
 

·
Registered
2021 Kia Sorento SX X-Line in Sparking Silver and 2019 Hyundai Tucson Sport in White
Joined
·
95 Posts
Good idea. I have a dash cam, just need to install it. I'm sure if I have the camera in place and the issue occurs, it will be an expletive laden recording!!
I just hope that when it happens again there's not a lot of traffic. That is the scary part - it has happened now twice in traffic and literally crawling across traffic when you have a gap to make a turn is frightening.

Worse case, when I take it in, I'll point them to this post so that they'll know I'm not crazy.
The issue mostly happened when I was coming to a yield sign or trying to merge from a exit onto the highway. It's like the dual clutch was still switching gears when I was slowing down and when I tried to speed up the system would not recognize it and still continue to stay in the same gear and slow down. Maybe ask them if that could be an issue with with dual clutch engine and see what they say. It might make them check other components that they might not be checking.
 

·
Registered
2021 Sorento SX AWD
Joined
·
10 Posts
Hello All,

Vehicle: 2021 Sorento SX

I've had vehicle for only 2 months and 1 day. So far I'm enjoying my vehicle EXCEPT for this issue I've experienced twice since ownership (once last month Feb and yesterday 23 March).

Scenario: In traffic at a stop either needing to make a turn or just accelerate forward. Accelerator does not respond to the pressure being applied and the vehicle barely moves even with pedal nearly to the floor (like crawls 1-2MPH) to get across the intersection and then it suddenly performs as if nothing happened. This is very dangerous as the vehicle is almost practically stalled and all you can see is oncoming traffic approaching... Wondering if perhaps the engine auto-shut off at stop gets confused or drive by wire technology / sensor for this vehicle is funky?

Not sure if anyone has experienced this. Unfortunately, not a simple issue to replicate and unsure of the methods for scanning and obtaining diagnostics.

Dealer hasn't heard of the issue yet, so I'll have to take it in, but thinking this could pop up on other vehicles. Very scary and very dangerous.

Cheers
So I had this same issue after pulling out from a side road and rolled into a bigger pothole. I thought I saw a traction control type light flash. Basically had to let off for a couple of seconds but got back on it as I had a car approaching quickly. Thankfully it picked up and took off from there. Hasn’t happened since.
 

·
Registered
2021 Kia Sorento SX Prestige X-Line, Aruba Green, Rust Interior
Joined
·
33 Posts
Let me ask for those that are experiencing this...is this only on Sorentos with 2.5 turbo and don't have AWD? Anyone with the turbo and AWD experiencing this?

I suspect people are experiencing the turbo's excessive torque to FWD vehicles combined with Kia/Hyundai's notoriously aggressive traction/stability control that will cut power as soon as any wheel spin is detected. Savage Geese's reviews have hammered this home on several Kia/Hyundai turbo FWD cars. Take a look at his FWD K5 video, around the 10-minute mark where he explains the issue:
He also has a good explanation in his Sorento review where he compared a 2.5 turbo FWD vs AWD X-Line and flat you says you need AWD if you're getting the turbo to actually make use of the power.

Just throwing in my 2-cents. I only got my X-line from the dealership yesterday, so far my acceleration test have been consistent and trouble-free. I hope anyone that has problems can get it sorted out one way or another.

Safe driving everyone.
 

·
Registered
2021 Sorento SX AWD
Joined
·
10 Posts
Let me ask for those that are experiencing this...is this only on Sorentos with 2.5 turbo and don't have AWD? Anyone with the turbo and AWD experiencing this?

I suspect people are experiencing the turbo's excessive torque to FWD vehicles combined with Kia/Hyundai's notoriously aggressive traction/stability control that will cut power as soon as any wheel spin is detected. Savage Geese's reviews have hammered this home on several Kia/Hyundai turbo FWD cars. Take a look at his FWD K5 video, around the 10-minute mark where he explains the issue:
He also has a good explanation in his Sorento review where he compared a 2.5 turbo FWD vs AWD X-Line and flat you says you need AWD if you're getting the turbo to actually make use of the power.

Just throwing in my 2-cents. I only got my X-line from the dealership yesterday, so far my acceleration test have been consistent and trouble-free. I hope anyone that has problems can get it sorted out one way or another.

Safe driving everyone.
I have the SX AWD version and have had the problem but only once.
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #16 ·
I have the AWD model and am having the issue


Sent from my iPhone using Tapatalk
 

·
Registered
Considering 2021 Sorento X-Line AWD
Joined
·
9 Posts
I just bought my AWD X-Line last week, and experienced this issue for the first time 2 days ago. Was at a stoplight, turned green, hit the accelerator, and hardly moved. Person behind me honked at me. Go figure!
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #18 ·
I don’t know if there is a formal place aside from the dealer service dept. for owners to log a complaint about the issue.

Since this is a new model year, service departments are probably relying on people to bring their vehicles in and they submit whatever findings to Kia.


Sent from my iPhone using Tapatalk
 

·
Registered
2021 Sorento EX T-GDI
Joined
·
71 Posts
Forward complaints to NHTSA and also bypass the dealership and let KIA corporate know. Just a thought if this happens, snap it into manual mode real quick and see if you can force a downshift or see what gear the car is in. Could be accelerator pedal sensor though.
 

·
Registered
'21 Kia Sorento SX, '03 VW GTI
Joined
·
21 Posts
Discussion Starter · #20 ·
Thank you Jasper1881!!

EXTREMELY helpful. As mentioned in some previous responses, dealer may not find the problem quickly, if at all and that would just compound my frustration and fear of getting smashed by traffic


Sent from my iPhone using Tapatalk
 
1 - 20 of 137 Posts
Top