Kia Forum banner

1 - 4 of 4 Posts

·
Registered
2005 Kia Spectra
Joined
·
183 Posts
Discussion Starter #1
Say everyone....

Has anyone else experienced problems with the brake lights sporadically not working on the 2004.5 and newer Spectras?

First one side, and now the other have been acting flaky, and periodically need the bulb pulled out and readjusted/fiddled with to make the brake light work properly.

These bulbs are the old style round base two "bump" electrode design.

I don't think that there's a broken wire causing this, necessarily. I think it has something to do with the wires being loosely mounted within the base of the socket, and how they match up with the bulb electrodes.

I've cleaned up the electrodes on both the bulb and the brass fittings in the base (which seemed to have helped some), but it seems like more of a positional issue with the wiring.

I've got them working okay right now, but the problem comes and goes. I fiddle them, and then it's good to go again - for awhile.

It's more of an annoyance than a dire problem. I'm just curious to see if anyone else has had a similar problem.

-SM
 

·
Registered
2007 Kia Magentis LX
Joined
·
156 Posts
Old thread, but never got a reply.

I had a similar issue on a 2005 Spectra I bought used for my daughters.

The car had 1157 bulbs in the sockets. These bulbs have brass contact buttons.

The car should have 2057 bulbs, with more pronounced steel contact buttons.

I also cleaned up the contacts in the sockets with a bit of sandpaper glued onto the eraser tip of a pencil.

All good now for the last 4 months.
 

·
Registered
Joined
·
1 Posts
Two Kia Spectra's with Tail light troubles

We have 2 2009 Kia Spectra's. The cruise stopped working on one. We took it in to the shop and they replaced some kind of break switch. This switch also controls break lights - which were not working too we found out. Once the switch was replaced the cruise and tail lights started working again. Then out of the blue the other car's cruise stopped working. We checked and tail/break lights on the car were not working. The switch was replaced and all is good. So we thought - my daughter just called to say she was back at school and the break lights won't go off when she parked the car. She turned the car on and off. Tapped the break. Set and disengaged the parking break and nothing worked. We ended up pulling the fuse and the lights went out to save the battery. We are calling KIA. Two cars with the same problem can't be a fluke.
 

·
Registered
2004 kia spectra ex, 2008 kia sportage lx
Joined
·
3 Posts
i too have problems with my rear lights. it seems to be the one on the passenger side. i have replaced the bulbs multiple times. i finally thought if i replace with LEDs it might end the problems. i was wrong. passenger side taillight and brake light out. looks like i have to find a multi-pack of 2057's or a real solution.

any tips would be helpful.
thanks
 
1 - 4 of 4 Posts
Top