Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Sorento XS 2.5 CRDTI 2006/2007
Joined
·
35 Posts
Discussion Starter #1
My Sorento SX is just over 12 months old, so far it has had two rear wiper relays fitted and it has just failed again. Has anybody had this problem or am I just unlucky


Steve W
 

·
Registered
2005 Sorento ex v6 automatic
Joined
·
537 Posts
Originally posted by Steve W@Nov 24 2005, 10:19 AM
My Sorento SX is just over 12 months old, so far it has had two rear wiper relays fitted and it has just failed again. Has anybody had this problem or am I just unlucky
Steve W
there maybe a problem with your wiper motor drawing too much current. i would ask them to replace the wiper motor as well

i have not heard of this type of failure before
 

·
Registered
Joined
·
116 Posts
I have a wiper problem in high heat. During the hot summer, spring days..my rear wiper doesn't like working. I got the motor replaced, and the switch for it on the inside(near the steering wheel) and still have the problem, I'm assuming its some contact of the wires..when the harness expands..they stop touching.
 

·
Registered
2003 Kia Sorento
Joined
·
606 Posts
There's a control module (with relays) in the hatch that could be causing your problem NY.

As for steve_w, I agree with beyond_help; I think they need to inspect or replace your wiper motor.
 

·
Registered
Joined
·
116 Posts
kiamech.. could you pm me in the other forming..explaining in a little more detail? maybe something i can discuss w/ a dealer next time i bring it in?
 

·
Registered
Sorento XS 2.5 CRDTI 2006/2007
Joined
·
35 Posts
Discussion Starter #6
Thanks for the info Kiamech. I have booked in for Tuesday at the Dealers, Iwill pass on your remarks.

Steve W
 

·
Registered
Sorento XS 2.5 CRDTI 2006/2007
Joined
·
35 Posts
Discussion Starter #7
My problem has been resolved, they changed both the wiper motor and the control relay.



Steve W
 
1 - 7 of 7 Posts
Top