Kia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello All,
My first post on here but I think I have read everyone elses! I've
had my Sorento for nearly a year now, but lately, unfortunately, it's not been
a positive experience! I've got a 2003 V6 3.5 XS Auto. On the way to Birmingham airport last july, the engine just cut out at 65mph without any warning.(We did make our flight..just.. and had a great holiday in the US!) The car meanwhile was recovered home where it has remained immobile ever since! I've had a mobile mechanic out to it, who ran a diagnostic, strangely no codes, readings for sensors checked out as did pump pressure (at pump)
He thinks its over fuelling as the only way he can get it to run (eventually!) is by disconnecting the electric supply to the pump and starting it.Then it will tick over reasonably sweetly for 5 secs or so then stop but it won't rev up.If you then reconnect the the supply it will start again for a few secs then stall, again won't rev and it won't restart. There is a smell of petrol.He thinks it's a ECU fault, but the ecu man thinks it isn't that, but a fuel pressure regulator fault (which he's come across before)
Firstly anyone any thoughts on this problem.
Secondly, where exactly is the fuel pressure regulator situated? I've looked all over the engine bay and can't see it.
Well hopefully the moblie mech will have another go this week but I don't hold out much hope. Anyway all contributions gratefully accepted, and of course I'll let you all know if we ever get back on the road again!
Best regards,
Steve.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Hi gee6,
Thanks for your reply and suggestion.I've had that switch off and bench tested it earlier in this saga and it works fine, so it's not that....I'm still suspecting this fuel pressure regulator thingy if only someone would tell me where it is!! (I've even downloaded a picture of it from a well known supplier..not in the UK of course..so I know what it looks like!)
Regards,
Steve.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Hi again,
Surely somebody must know where this fuel pressure regulator is to be found? Thanks in anticipation...
Steve.
 

·
Registered
I now drive a 2003 S-10 Had an 03 LX 3.5 Sorento
Joined
·
2,363 Posts
I believe it is attached to the high pressure rail (#2)under the ICV. In the pic it is the object on the PS rail, rear. HTH
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Dear nstoolman1,
Thanks for that info.No wonder I couldn't see it with just a cursory look, it looks well hidden!
Regards,
Steve.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Hi to everyone,
Well good news at last, problem solved after weeks off the the road and hours of website research.A big thankyou to "allaghast" who posted on the Sedona website a couple of years ago for pointing us in the right direction.Turned out to be collapsed internals of one of the "cats".. there are 3 on this model. Mobile mech fellah did as suggested in the post and disconnected the pre-cat sensor allowing gas to escape..started first time ,revved up and didn't stall. We're still investigating but main cat ok..had bits in..will investigate which of the other two (or both) are blocked.Will probably just bash out the innards for now and see how it goes. I suspect the cost of replacing these two might be exorbitant,but at least we're mobile again (or will be when everything is put back)
Anyway hope this is a help to other none starters with similar symptoms.
Regards
Steve.
 
1 - 7 of 7 Posts
Top