Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, I have a 2003 Sorento Ex, with the 4WD always on ( auto mode). When I used it on snow, it feels like a 2wd, only the rear is having power. There'is no light in the dash that indicate a problem. Also, the 4 low mode is not working either. Is there a way to determine where the problem came from?

Thanks
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,878 Posts
First check that the "TCCS" fuse in panel at drivers footwell is installed and actually intact. Test it, don't just look at it :)
Removal of that fuse is a quick "fix" for dodgy transfer case or unevenly worn tyres creating problems.
I would normally suggest checking that the front prop-shaft is actually installed (removel being a more permanent solution to fuse removal) but as you say that 4Low is not working I doubt that would be your problem.
A failed Transfer Case control unit (the above TCCS fuse supplies it's power) may be on the cards or a wiring problem. Hard to tell. Any codes?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks,
The fuse is OK, check it with ohm meter. The Front propeller shaft is brand new. Concerning the codes, my tester only enable me to check the codes from the engine and transmission,is there another way to check if the transfer case module is OK. In order to check if it's a wiring problem, what test should I perform. I have read on other post that there is an actuator on the front Differentiel and if this is not working the 4wd will not work. This was for a part time 4wd (Model with the option to go 2wd), is it the same case for my model, because I haven't find the air pump (actuator).
 

·
Registered
08 2.5 CRDI Sorento Titan Auto
Joined
·
1,878 Posts
is it the same case for my model, because I haven't find the air pump (actuator).
No, you won't have that on your model. Do the 4WD warning dash lights come on when you first turn on ignition key to start? Do any flash? (The TCCU has a diagnostic sequence that should give coded flash - like morse code - on errors).
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Hi, the 4wd light and 4low light light for about 2 seconds then turn off. No flashing. Thanks.
Just for your info, this summer I have change the clutch pack inside the Transfer case, because a Mech at the garage told me it could be that, But it does not solve the problem.
 
1 - 6 of 6 Posts
Top