Kia Forum banner

1 - 9 of 9 Posts

·
Registered
2011 Kia Sorento LX Bright Silver - W/ Package - Heated Seats, Backup Sensors & Camera
Joined
·
27 Posts
Discussion Starter #1
My 2011 Sorento LX has been having a weird situation when exiting the vehicle.

When I open the car door and remove the keys it keeps 'dinging' like I left the lights on or something along those lines. The door open does illuminate, but I checked all accessories and such and if I close the door the open door illumination goes away and so does the dinging. However, if I ignore it and get out, close the door.. Then it won't lock with the keyless entry. If I come back a few minutes later, then it will lock.

Has anyone experienced this, or perhaps have an idea if this is something that might be covered under warranty? 20k miles on it.

Thanks!
 

·
Registered
2012 Kia Sorento SX AWD (Titanium Silver); 2013 MINI Cooper S Hardtop, 6-sp. manual (Eclipse Gray)
Joined
·
123 Posts
Obvious question: You haven't accidentally left the spare key fob/smart key somewhere inside the vehicle, have you?
 

·
Registered
10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Joined
·
1,410 Posts
Obvious question: You haven't accidentally left the spare key fob/smart key somewhere inside the vehicle, have you?
His is an LX, so it is not a smart key.

My guess could be that maybe the key in switch may be going bad. Does it have just the standard keyless entry, or remote start? If remote start, factory or aftermarket?
 

·
Registered
2011 Kia Sorento LX Bright Silver - W/ Package - Heated Seats, Backup Sensors & Camera
Joined
·
27 Posts
Discussion Starter #4
It's just the standard key - and no remote start. I've checked the lights, fog lights, opened/closed all doors, interior lights etc. Still does it almost every time now — beginning to get a bit frustrated with it. I've also checked it with both of my remote keys, thinking maybe the battery was going bad in the main key, but that proved to be unfruitful.
 

·
Registered
10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Joined
·
1,410 Posts
Its probably something with the ignition switch, if it thinks the key is in, the doors won't lock.
 

·
Registered
2011 Kia Sorento LX Bright Silver - W/ Package - Heated Seats, Backup Sensors & Camera
Joined
·
27 Posts
Discussion Starter #6
That makes sense. This sounds like a warranty fix, ya think?
 

·
Registered
2012 Sorento EX AWD CRDI; 2007 Sportage EX CRDi 4WD; 1967 Mercedes 250S; 1958 DKW 3=6
Joined
·
372 Posts
My Sportage had a similar issue a while back; When the key is removed the flap that covers the keyhole sometimes didn't slide back in and the vehicle thinks the key is still in the switch. When you open the door it "dings" to warn you that the key is still in the ignition and of course you can't lock the doors.

I just jiggled and fiddled the key in the ignition switch a few times and it rightened itself. Probably caused by dirt in the switch.
 

·
Registered
2011 Kia Sorento LX Bright Silver - W/ Package - Heated Seats, Backup Sensors & Camera
Joined
·
27 Posts
Discussion Starter #8
I checked it for the flap issue and dirt — that didn't seem to be it. Guess I'll have them peek at it when I take it in for an oil change next week.

Thanks for the help!
 

·
Registered
Joined
·
1 Posts
2010 Kia Sorento would not lock with remote.

I had a similar issue with my 2010 Kia Sorento. I pressed the lock on the remote, and the lights didn't flash to indicate it had locked. I was about 20 metres from it and presumed I was too far to hear the door lock mechanism. However it flashed when I pressed the unlock button. The first day I thought I just had not seen the indicators flash, but realised the next day the doors had not locked.
I gave it a couple of minuted thought, and tried to do a reset with the fuses. No good.
I then thought about why the mechanism would say I can't lock the doors, and concluded it might not be getting the signal that one or more doors might still be open. Checked all the doors, including the rear door/tailgate. They were all closed.
I then went to the front passenger door and pressed the door sensor half a dozen times, closed the door. The vehicle locked when I tried it.
It hasn't faulted since.
I told the KIA people when I last had it serviced to put on their records, but that it was not an issue and has been working fine. When I picked it up, they told me they had looked at it and couldn't find anything wrong with it, and had to put up with the smell of WD40 for two weeks. I didn't use any myself when I pressed it.
I would suggest checking all of the doors, as I was just lucky finding it on the first door I checked.
 
1 - 9 of 9 Posts
Top