Kia Forum banner

1 - 9 of 9 Posts

·
Registered
Kia Sorento 2010 Model, 2.2 CRDi 4WD, 7 seater Diesel
Joined
·
4 Posts
Discussion Starter #1
good day gents.

im new to this form so sorry if its posted in the incorrect place.
I bought a 2010 kia sorento 4x4 2.2 diesel its been a nice car to have for the last 8 months. yesterday I drove home fine and parked the car then my wife wanted to go to the shops 15 min later the car wont start at all, yet the engine turns over when you press the push start.

I pulled the diesel pipe that feeds the comin rail and it seems its not supplying diesel I don't see any edc codes for errors ive also left the battery disconnected over night thinking to reset the computer but no luck, looks like it starts when spraying quick start in the air box so it looks like its just not supplying diesel.

ive checked the fuses under the hood and swopped the aircon and pump relay still didn't help.

any suggestions on what I can look out for or try so that I don't have to tow the car to the garage to have it fixed also don't want to break the bank as the steering controls also stopped working a few months ago so I still need to replace that clock spring

thanks for the help
 

·
Registered
Sorento 2.2CRDi (2013)
Joined
·
105 Posts
I had similar problem at my XM 2010. No error code, not coming diesel from fuel pipe on filter. I towed my car to service and they decided to replace fuel pump in fuel tank (there is small supplying fuel pump) as they were not able to find any other problem.

After replacement I was able to start but I drove 2 km to shop and after returning to car I was not able again to start my car :rolleyes: They took a car again into service and after few days they found a corrosion on some pin in wiring for that small supplying pump.

So my problem was just that cold joint in wiring :unsure:
 

·
Registered
Kia Sorento 2010 Model, 2.2 CRDi 4WD, 7 seater Diesel
Joined
·
4 Posts
Discussion Starter #3
thanks it looks like im going to have to get the car towed tomorrow and see what they find hope its something small and wont take long to resolve
 

·
Registered
2019 Kia Sportage. SX with AWD. 2.0L Direct Injected Turbocharged & Intercooled Gas.
Joined
·
631 Posts
Good Luck! Let us know if its a common issue with Beda!
 

·
Registered
Kia Sorento 2010 Model, 2.2 CRDi 4WD, 7 seater Diesel
Joined
·
4 Posts
Discussion Starter #5
ok, so it looks like I'm making progress and so far I need to replace the entire diesel pump due to some wire on the tank burning off in the pump will see if I got more pics from the mac when I get the car back to tomorrow
pump fault.jpg
 

·
Registered
2019 Kia Sportage. SX with AWD. 2.0L Direct Injected Turbocharged & Intercooled Gas.
Joined
·
631 Posts
Well that's not good.
 

·
Registered
09 kia spectra ex,04 Neon,04 Chry. T&C, 08 Pontiac G6 gt
Joined
·
2,168 Posts
That typically happens to the connector due to an overheated and dying in tank pump. Most usually from the filter pick up (in tank) being clogged.
You are right that the whole pump assembly needs to be replaced and then replace/repair the electrical connector.
Good Luck, and let us know how things work out.
 

·
Registered
Kia Sorento 2010 Model, 2.2 CRDi 4WD, 7 seater Diesel
Joined
·
4 Posts
Discussion Starter #8
ok, so car is now running ok again after replacing the pump,
you can see where the connection has burnt on the inside of the pump

IMG_20200326_102103.jpg
 

·
Registered
Sorento 2.2CRDi (2013)
Joined
·
105 Posts
So close to diesel :eek: it could end more worse ... lucky you (y) Enjoy the car again ;)
 
1 - 9 of 9 Posts
Top