Kia Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have recently purchased a Sorento Auto Diesel. I am enjoying the vehicle but taking a little time to get used to towing a boat on the beach with it as the turbo only comes in when the revs climb.

When loading the boat onto the trailer, which takes a little enrgy as you force the trailer under the boat, the engine revs pick up but the car does not move or the wheels do not spin. It feels as though the torque converter is slipping,- similar to when a clutch slips.

Any comments
 

·
Registered
Joined
·
15 Posts
:unsure:
Uh, how much slippage?
The torque converter is suppose to slip otherwise the car would never idle in drive.

Allen
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Originally posted by blue m and m@Jan 3 2005, 06:36 AM
:unsure:
Uh, how much slippage?
The torque converter is suppose to slip otherwise the car would never idle in drive.

Allen
Thanks for your input Allen, but when one accelorates the vehicle should move or the tyres should spin in the soft sand.
 

·
Registered
Joined
·
153 Posts
Can you give some more information like:
1. Dry / wet sand or other surface?
2. Do you use low gear?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Originally posted by Murphwiz@Jan 4 2005, 06:44 PM
Is this a 5 speed auto?
There is a recall on the 5 speed transmissions for reverse gear faults.
Yes I use 4 low and the sand is beach sand, firm and a little damp.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Originally posted by kiasorento@Jan 4 2005, 03:45 AM
Thanks for your input Allen, but when one accelorates the vehicle should move or the tyres should spin in the soft sand.
I think it is a five speed, - never counted the gears but it does have overdrive so i think it is 5 speed.
This problem has only occured in reverse. I have now put a tow hitch on the front and will see how it works when going forward
 
1 - 8 of 8 Posts
Top