Kia Forum banner

1 - 7 of 7 Posts

·
Registered
2013 KIA Sorento SX
Joined
·
30 Posts
Discussion Starter #1
I just had it for 4 weeks and everything seems to work fine. But the past couple of days it doesn't start. When I press the break, it feels very hard. The only way I was able to start it again is to press the start button twice without pressing the break pedal. After that the break is not as hard and the engine starts with no problem.
 

·
Registered
2013 Kia Sorento EX V6
Joined
·
198 Posts
I never heard of this issue yet, you just need to depress the brake ever so lightly for the push button to start the Sorento...not sure why the brake would feel hard to depress is your wheel in the lock position? is there something under the pedal getting in the way like the mat?
 

·
Registered
10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Joined
·
1,411 Posts
If you keep pumping the pedal with the engine off, it uses all the vacuum for the assist, which causes the pedal to get hard. After the engine starts, the vacuum for the assist is restored. Even with a hard pedal, though, it should still move enough to allow the engine to start. Make an appointment with your dealer to get it looked at.
 

·
Registered
2012 Sorento EX GDI
Joined
·
42 Posts
I suspect a brake switch issue. Last I was in service, the kid mentioned seeing a spike in starting issues due to it being faulty intermittently.

Press and hold the start button for 15 seconds and the car will bypass the interlocks and start. Obviously you need your key fob still.
 

·
Registered
2013 KIA Sorento SX
Joined
·
30 Posts
Discussion Starter #5
lxedition,

I tried your method of pressing the brake lightly and it worked perfectly!:)

I barely touch the brake pedal and the Sorento starts every time. :D
 

·
Registered
Joined
·
1 Posts
2013 Sorento not starting

My Sorento will not start on days over minus 19. If I put it in the garage over night it will start, but outside at work when it is started all power comes on, radio, lights, dash needles but not even a crank just nothing, wait a bit try a few more times starts right up. I have a 2010 Magentas (Optima) and it can sit out all night and all day and start no issues. Brake switch replaced, fuse box and fuses/switches replaced. Dealer not helping because it "never does it when I get it towed to them". I believe it is an ignition issue but they can't get a code on the computer so they will not repair.
 
1 - 7 of 7 Posts
Top