Kia Forum banner

61 - 79 of 79 Posts

·
Registered
2017 Kia Sorento EX T-GDI AWD
Joined
·
4 Posts
Glad to see I'm not alone in this. These are photos from Dec 30, not too long after purchasing the car. Since then, this issue has happened probably 6-8 more times. Reported it on UVO, requested service from the dealer and have had zero replies. My guess is they know about the issue but are trying to avoid it. I just scheduled another service request this morning as it just happened again. As I'm in the middle of moving, it's difficult to carve out time to go across town and harass them in person, but it will eventually come to this in either this location or my new one.

I've taken the car on one long road trip (1700 mi round trip) and the SCC worked flawlessly. When driving to work, less than 9 miles, it's failed on me. It's happened at low speeds, moderate (~55) and higher speeds (~70). It's happened in various day / night conditions. Seems almost impossible to recreate. One person mentioned their dealer trying to blame the trailer wiring, but I sincerely doubt that's an issue since it's happened before (most of the occurrences) and after (1-2 times).

My honest guess is that there's an issue with the CAN system, more specifically one of the IC's involved. Since the CAN bus runs at <1ms timing, anything that interrupts this timing can throw a system off. I see the same issue on rare occasion in the medical equipment I service, where the CAN system hangs up, or a buffer doesn't clear, and it essentially hoses the system until it's reset. One long running production of a poorly created IC could be an issue, but again, this is a best guess. As all of you have noticed, the error messages are cryptic and offer no real data.
 

Attachments

·
Registered
2017 Sorento SXL AWD
Joined
·
20 Posts
Reported it on UVO, requested service from the dealer and have had zero replies. My guess is they know about the issue but are trying to avoid it.
Maybe the UVO scheduling service just doesn't work? I haven't tried it myself so no clue. Either way, there is no reason for the dealer to avoid the issue since the software update seems to work. Just call the dealer and tell them you want to schedule an appointment to apply the software update and go from there. It took my dealer 50 minutes to do the update but I suspect it would have been faster if I told them I was waiting rather than leaving and coming back.
 

·
Registered
2017 Kia Sorento SXL V6 AWD Titanium with Black Interior
Joined
·
264 Posts
this is a best guess. As all of you have noticed, the error messages are cryptic and offer no real data.
There is no reason at all to be guessing. The problem is known and the solution is known. You will find the exact software update that needs to be applied to your vehicle in a post from me in this thread and/or the other one which I cross linked.
 

·
Registered
2015 Kia Sorento SX Regency Red, 2012 Kia Sorento SX, 2011 Toyota Hiace
Joined
·
573 Posts
The one time I tried to use the UVO scheduling service, I also heard nothing. I suspect that it doesn't work.
Hi!

I've been reading this thread from page 1 and thanks to all of the very informative posts. How's your car been doing? Were you able to go through the process of claiming your Sorento as a lemon?

It's pretty scary to have an issue like that with a brand-new, current-MY Sorento - and you would think that buying a 2017 would be better than 2016.

It's good that the software update is proving to be a fix - and may that be a long-term one.

Good job guys! :)
 

·
Registered
2017 KIA Sorento SXL V6 AWD
Joined
·
31 Posts
Discussion Starter #66
I've been reading this thread from page 1 and thanks to all of the very informative posts. How's your car been doing? Were you able to go through the process of claiming your Sorento as a lemon?

Good job guys! :)
I'm assuming that although you quoted me, you were asking someone else about claiming their Sorento as a lemon, since I have never mentioned doing so...
 

·
Registered
2015 Kia Sorento SX Regency Red, 2012 Kia Sorento SX, 2011 Toyota Hiace
Joined
·
573 Posts
I'm assuming that although you quoted me, you were asking someone else about claiming their Sorento as a lemon, since I have never mentioned doing so...
Sorry for the confusion, I thought that you're the one since you're the TS (effect of reading all 7 pages of the thread in one sitting :D!
 

·
Registered
2017 Sorento SXL AWD
Joined
·
20 Posts
Well, at 2500 miles I got my first smart cruise control error.
I really would love to have more information on the specific conditions that result in the error. 2500 miles is a long way to go without the error while some have gotten it much more frequently. Seems so random.

I had the update applied on 2/8 and have used SCC every chance since, including several multi-hour drives including periods of full stop and go traffic without issue. I would love to declare everything fixed but the randomness of everything makes it hard to do that with any certainty. I am crossing my fingers.
 

·
Registered
2017 Kia Sorento SXL V6 AWD Titanium with Black Interior
Joined
·
264 Posts
I really would love to have more information on the specific conditions that result in the error. 2500 miles is a long way to go without the error while some have gotten it much more frequently. Seems so random.
I believe, but can not prove, that one thing that may cause the problem is trying to "resume" before you "set".
 

·
Registered
2017 SXL AWD
Joined
·
129 Posts
I really would love to have more information on the specific conditions that result in the error. 2500 miles is a long way to go without the error while some have gotten it much more frequently. Seems so random.

I had the update applied on 2/8 and have used SCC every chance since, including several multi-hour drives including periods of full stop and go traffic without issue. I would love to declare everything fixed but the randomness of everything makes it hard to do that with any certainty. I am crossing my fingers.
I only use SCC on road trips and/or on the highway. That might explain why I only now encountered the error.
 

·
Registered
2016 Sorento SX AWD 3.3L
Joined
·
189 Posts
There's a usb according to my dealer. They did a reflash called SA269 HECU unit update thinking it would help. Haven't tested it to see yet.
 

·
Registered
2017 Sorento EX V6
Joined
·
24 Posts
This finally happened to me a couple of weekends ago with a little over 1500 miles on my EX V6. Mine happened a few seconds after a car cut in front of me, a bit close but not panic close, and I think I did tap on my brakes a little. Probably a coincidence, that day my Android Auto kept going into an endless loop of searching my USB media and then failing and then repeating, and so on, whenever I tried to start Pandora, until I pressed the reset button at the upper right corner of the screen. But unlike an earlier issue with this unit being stuck in night lighting even in daylight, resetting did not stop the problem from coming back. I finally uninstalled Android Auto, and a week later reinstalled it and have not had this issue again yet.
 

·
Registered
2017 Kia Sorento SXL V6 AWD Titanium with Black Interior
Joined
·
264 Posts
The dealer installed the recent "HECU" "B SA269 Hydraulic Electronic Control" software update today. They did not do a camera alignment because Kia believes the software update will solve the problem.

Kudos to Century Kia of Tampa. They drove me to work and back (1/2 hour each way x 2 for my salesman). They took care of the problem. They washed and vacuumed my car.

Time will tell if the problem occurs again.
I posted the message above on 01-24-2017, 06:33 PM.

I have not had the problem since.

Today I received a letter of apology and a $50 gift card, in the mail, from KIA.
 

·
Registered
2017 Sorrento SXL
Joined
·
18 Posts
Just got back from the dealer .... This was the 5th time I encountered this issue of all the lights coming on. I originally reported the problem in this forum back in September 16. Well after having all the connections tested, (this did not fix anything), and having the lane departure SA applied (still no fix), it happened again. This time the dealer was able to find the new "SA269 software" and they applied it... So I am now crossing my fingers that this will finally fix the issue. My only complaint is that since I had reported this issue before to two different dealers why did KIA not notify me that there was a potential fix... I had to encounter the problem on my own and take it back once again. Don't get me wrong I love the car but the customer service tracking database should have alerted somebody at KIA that this was an ongoing issue since I reported it several times in the past. Hopefully someone at KIA will get this kind of customer tracking working.
Gary
 

·
Registered
2017 KIA Sorento SXL V6 AWD
Joined
·
31 Posts
Discussion Starter #78
Finally reporting back...

We had the software update applied a couple of months ago, and have had a couple of longish trips since with no issues. Heading off on another longer trip soon, so fingers crossed!
 
61 - 79 of 79 Posts
Top