Kia Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My check engine light was on, took it to the dealership and they gave me a long list of things I needed to do to fix the issue. My family member is a ex machanic who did all the work for me. When he rotated my tires he was looking for a clip or something for the back tires. Now that he did that and couldnt find this clip thing, my gas pedal feels rough and it smells like something is rubbing and burning in the back wheel area. Can anyone fimilar with this tell me were or what this may be? Id rather not take it somewhere and have them say " oh this and this needs to be done" and spend money on something pointless.
 

· Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,196 Posts
im guessing its a clip for the rear brake shoes...



 

· Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,196 Posts
Originally posted by timspath96@Dec 22 2004, 10:45 AM
do you know if they is one? and whereis it if so?
Thanks
you will have to take the rear drum cover off.. I know there is a clip and spring in there........ take off the one side that isnt missing see what it has and look at the one that is missing you will see it.



 

· Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,196 Posts
Originally posted by timspath96@Dec 26 2004, 03:28 PM
I figured out my problem ....thanks!
if you dont mind me asking what did it end up being?



 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top