Kia Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My vehicle has been to 1 mechanic and then had to be towed to the dealership. I've had it for about 4 days (BACK FROM THE DEALERSHIP) and the vehicle is acting up again. When driving- the car will sputter and it's like it's not getting enough gas. Sometimes while in 1st, 2nd, 3rd, 4th or 5th the I'll push on the gas and it gets NOTHING. Absolutluy no gas. Fuel pump has been replaced more then once, the gas tank was dropped and cleaned out along with allll the fuel lines and stuff PLUS the fuel injectors. 800 bucks to the first mechanic- 700 bucks to the dealer.

The 1st mechanic couldnt figure it out- the dealership said it was maybe bad gas but most likely someone put something in my gas tank?!??? WELL- BULL S***. Because here we go again!! When it started doing this the first time the car eventually (3 days) shut off all together and wouldnt even start.

PLEASE HELP ME!!!!!!! Also, the ac was "fixed" by the 1st mechanic something was replaced, but the az only blows cold air 3 out of 4 times. I live in tucson az with a toddler- AC IS ESSENTIAL!!
 

·
Registered
Joined
·
35 Posts
I did have a Mazda truck that did the same thing........no power,and getting no gas.I took the tank off,and replaced with a "used" pump,,lasted a day,then the same problem.I replaced the fuel filter only to find that there was excessive rust in the gas...due to a rusted gas tank inside?
Was this gas tank in good shape when the mechanic repaired your pump?......Was it rusted at all inside?Could be also a bad connection to pump?
I dont know if this helps,,but i went through all this.Ill tell ya ,it can be really bothersome!
glen101
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Thank you for replying to me!! Well, the dealership said that there was something crystalized in the gas tank and fuel lines and gunk on the fuel injectors. This is what made them think someone put something in my gas tank- though unable to identify what it was or when it happened.

So they cleaned it allllll out and soaked the fuel injectors for 3 days and when I got the car back it was driving like a dream. For a whole 4 days and now it's doing the same thing. I don't know what was replaced and what was only cleaned- all I know is that 2 different mechanics attempted to work on this problem and nothing:( I'm ofcourse calling the dealer on monday!!
 

·
Memorial Super Moderator
Joined
·
2,861 Posts
Don't dismiss contaminated fuel, my nephew bought a Nissan that the owner thought had wrecked engine by amount of smoke from exhaust and no power. I fiddled around with it and eventually had a look in the fuel tank, looked ok. flushed it out and even got my arm up inside and wiped out with paint thinners. Refilled and it still smoked for two full tanks but run a lot better. When we let some fuel sit in a bottle and separate all was revealed, someone had deliberately added some type of hydraulic oil to the previous owners fuel tank and that was the problem. It was clear oil and very hard to notice as it didn't feel that oily or smell when you handled it in the fuel tank mixed with petrol. My nephew got years of good use from the car, it is amazing the things you come across when working on cars.
 

·
Super Moderator
Joined
·
6,851 Posts
Maybe Sugar? see this link....
Car Talk

glen101
yours sounded like Bleach. Mythbusters did a segment on "bleach in the gas tank" it caused lots of problems just sitting in there and one of them was lots of rust in the bottom of the tank

Tried to find crystallized + gas tank on google found someone put crystal meth in their tank to try to get it across the border (got caught)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Well, there is no smoke or anything coming out of my engine. It's just not getting gas or something. It's getting worse and Im praying it'll make it back to the dealership. Whether it was bad gass, something in the tank or the fact that it was just sitting there forever- EVERYTHING was cleaned out. It was driving perfect for a whole 3 days and now it's driving exactly how it was before it completly died.

So, does it take a few tanks of gas to recover even though it was previously although briefly running FINE? Why didnt the cleaning out of the gas tank LAST?? I'm so depressed.

I'll be sure to let you know what the dealer says. THANK YOU for all your replys.
 
1 - 8 of 8 Posts
Top