Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Yesterday my 2000 Sephia 1.8GS (bought brand new in 2001) couldn't start up. I thought it was flat battery and I called service. They came and took my car to nearest KIA service center where they called me later that engine is dead because there was no oil in it!!! I DO CHECK oil level periodicaly and it was always ok so I guess there was some kind of leak. Sephia is 3 and half years old so 6 months after warranty ended and it has 36.000 kilometers. The car was maintained by the book in KIA service center, so HOW COULD THIS HAPPEN??? Ok it could happen but I can't realize why the service told me I will have to pay for new engine or take that car to dumpyard!!! Now I'm without money and without car. I was very satisfied with KIA until now and I have no idea do I do.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Here it goes how the story continued...

I finaly got back my Sephia. After 2 weeks. They found out that it was just a flat battery!!! TWO WEEKS for something I fix myself!!! On the first day they said engine died for sure and it will need to be replaced. For two weeks I was on the edge of my nerves because I didn't know what was actually wrong and how much will it cost me.

This just proved that Kias are not bad cars but their system in Slovenia IS.
 

·
Registered
Joined
·
25 Posts
Glad to hear you got your problems resolved. That is odd how they said your motor was blown/ceased up. Would have killed me.

Congrades on your good luck! Would have sucked had they replaced the motor only to find the battery was dead.
 
1 - 3 of 3 Posts
Top