Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 07 Sedona with the 3.8 engine.
The engine went into P2106 TAC System Forced Limited Power and displayed the following two fault codes:
P1295 Manufacturer Contrl Fuel Air Metering AND
P161B Manufacturer Contrl Auxiliary Inputs Auxiliary Outputs

The dealer indicated to me to change the Throttle Body position sensor which I did. During the change, I noticed a tear in the Air Intake Tube which I repaired with Gorilla tape to seal it up.

I also reset the check engine light by disconnecting the battery for about 10 minutes.

The engine will still not run above an idle and sounds like it is getting a lot of air and no fuel (kinda a WAAAAAA) sound when you press on the accelerator.

Any thoughts?

I was kinda hoping to find out more about the codes.

Thanks,

Ken
 

·
Registered
Joined
·
1 Posts
P161b

My 2007 Optima threw P161B, P1295 and P2106 this morning. I think it is in the limp mode because it will not run much above 20 mph. I have been searching for info on these codes with little luck :(; any help out there?
 

·
Registered
Joined
·
1 Posts
P161b

My 2007 Optima threw P161B, P1295 and P2106 this morning. I think it is in the limp mode because it will not run much above 20 mph. I have been searching for info on these codes with little luck :(; any help out there?
I’m getting the same thing right now on my 2007 Sedona. Was hoping to have someone respond to you so I could get an answer. I guess I’ll have to just take it to a garage. FML
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,842 Posts
I’m getting the same thing right now on my 2007 Sedona. Was hoping to have someone respond to you so I could get an answer. I guess I’ll have to just take it to a garage. FML
Using the below link, please add location and vehicle (year & model) to your Profile/Account Details

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD

https://www.kia-forums.com/account/account-details


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 

·
Registered
06 Grand Carnival
Joined
·
381 Posts
I’m getting the same thing right now on my 2007 Sedona. Was hoping to have someone respond to you so I could get an answer. I guess I’ll have to just take it to a garage. FML
Hi You are responding to a 10 year old post to a different model,
What are YOUR codes? What efforts have you done to trouble shoot?
 
1 - 5 of 5 Posts
Top