Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Kia Sedona 2004 LE 2.9 CRDI
Joined
·
23 Posts
Discussion Starter #1
This has happen twice now and it's bothering me now, anyone had this happen to them?
When the cars being running at normal temp ie first time i had done about 100 miles the second time i had only done about 6 miles when i came to a roundabout so slowed down ie tickover speed and the engine just stalled, same thing happen again when i took my foot of the accelerator along a straight bit of road it did the same, this was 3 weeks apart, she always starts again Immediately. Is a sensor breaking down? or fuel, or lose connection somewhere?
Any help please.
 

·
Registered
'02 Sedona 3.5L
Joined
·
75 Posts
Is the check engine light on? This could be cause by all kind of possibility like you mentioned. I would take it to where someone has a code reader such as dealership to see if there any problem codes. Then start from there.
 

·
Registered
Kia Sedona 2004 LE 2.9 CRDI
Joined
·
23 Posts
Discussion Starter #3
Thank you for the reply, no engine management light came on at all, and it always starts great, its always the same starting only got to show it the key, I have had a feel of the pedal electrics block all ok, its got 60.000 on the clock now, had a new fuel filter about 3 months ago, checked pipes to it all ok, i always add a bit of redx diesel treatment, may pop it into my local kia or may give them a call see if they have heard of this before, thanks,
 

·
Registered
Kia Sedona 2004 LE 2.9 CRDI
Joined
·
23 Posts
Discussion Starter #4
Just to update, phoned my local kia dealer it's £45 just to plug in diagnostic and road test but they did say if the engine management light has not come on no code will be held, so not much help. Will keep using it and see what happens.
 

·
Registered
Kia Sedona 2004 LE 2.9 CRDI
Joined
·
23 Posts
Discussion Starter #5
Further update,, just cut out again yesterday, came to a road junction slowed down and the engine just stopped, pulled into the side of the road turned the starter away it went again. This is getting to become dangerous as the power steering goes. Can anyone shed what the fault maybe please. Could take it to Kia but unless it happens there then they can't find it. My guess is it could be a lose connection somewhere but don't know where to check. Help....2.9 crdi
 

·
Registered
Kia Sedona 2004 LE 2.9 CRDI
Joined
·
23 Posts
Discussion Starter #6
Another question,,, would Kia diagnostic check pick up any code if the engine management light does not come on at all?
 
1 - 6 of 6 Posts
Top