Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
HI ALL.
sorry for my english

i'm a sportage early 97 2.0 16V dohc 4X4 80k km owner who's living in a 2 month long bad dream.
One day the car starts with only three cyl, white smoke and really rough idle and MIL light.
i immediately changed: oil, air filter, sparks, ignition coils, ignition coil wire and cleaned the IAC valve and the things changed in better.
after that the engine starts at 4 cyl but always rough idle, MIL light, but become perfect when is warm.
i felt so lucky when i find this forum because our forum in italy http://sportage.altervista.org talks about the most common diesel version)
After a deep lurk of this forum i tried the first experiment; i disconnect the battery ground to reset and clear the trouble codes.
now the engine starts better and not so rough like before.
that make my think the problems are caused from a bad measure from the air or engine temperature sensors.
can be???????
i 'd like to buy a code reader but i cannot find the OBD2 connector in the zone 3 where is indicated in the OBD2 location files )
But i've find under the bonnet behind the air box a diagnose connector ( that means my car is a 95 model ? without OBD2????????????????)
what can i do?????
thank for any help

Marco
 

·
Registered
Joined
·
349 Posts
I am not certain but I think 1997 European Sportages were OBD-I. So it would require a visit to a Kia Dealer to readout the trouble codes.

Sorry that I could not provide more assistance.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
thanks for the answer Axe Man
it's really a bad news :crying: :crying::crying::crying:

i already asked to my dealer’s mechanic but he said to me :
1) the ECM do not keep the code errors in memory :wacko: (????????????)
2) all my troubles are caused from a broken plastic pipe :wacko: (????????????)
I decided to try to find the solutions to my self, but i cannot have access to kiatechinfo.com because they do not accept payment from outside US

so i need a help

1) where i can find the diagram of autodiagnose plug?????????????
2) does exist an interface autodiagnose to obd ????????????

thanks
marco
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
:grin: :grin: :
finally i resolved my problems

At the half of august decided to test MAF - IAC and Coolant temperature sensor

I discovered the IAC was perfect but the MAF was dead (the engine runnig better with the MAF unplugged) and the coolant temperature sensor was not in good ealth (at 25°C=75°F the measure was 33 Kohm instead of 2 kohm and make the ECM think the temperature was below 0°C=32°F)

i call kia service in Milan ( the only one open in august) and they asked me 390 euro (507us$) for a new MAF :eek: :eek:

then i buyed one used from a cars demolitor (120 euro) :eek:fftopic:

i've been lucky and the sportage stops to be rough but was still misfirig in the first 10 miles of use

yesterday i find a new coolant temperature sensor and replaced

this morning after a cold rainy night the sportage start ad run PERFECT :sunce: :sunce:

this adventure cost me in three mounth 755 euro (981 us$) and i'm bl**y tired.

150 euro to change oils filter ad front brakes (normal maintenance)
250 euro to cleaning injectors (money thrown away)
200 euro to change sparks , wires and coils
120 euro to buy a used MAF (from Rover 75 and lucky because works perferct)
35 euro to buy a new coolant temperature sensor

ciao
Marco
 
1 - 4 of 4 Posts
Top