Kia Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
kia sportage 1st gen 1996 2.0dohc gasoline 4 door manual 4x4

hi guys, I have a problem with my sportage, it has a rough idle, it seems that the engine is going to die, but when I accelerate it on high ways it's smooth, and fast. When the aircon is ON and cruising at 2000rpm if I remove my feet from the gas pedal sometimes it remains on 2000rpm even on neutral and then slowly decreasing to 1000rpm or idle. I tried to search here but I cant find same problems with me. Hope you can help!
 

·
Registered
Joined
·
2,216 Posts
Greetings,

The Idle Air Control (aka "Idle Speed Control") valve ( "IAC / ISC" ) is the valve that meters air to the Throttle Body -> maintains Idle,

A dirty/sticking IAC valve may be the cause,

Illegal Air being introduced in the rubber piping in between the MAF sensor and Throttle body may be another cause,

A small vacuum leak at the Intake Manifold may also be a possible cause,

--
Recommend checking the tubing from the air filter box (air box) -> to the Throttle body for any cracks, loose clamps, or leaks,

Recommend checking all vacuum hoses & ports at the Intake Manifold, all ports should have either have a hose attached that is in good condition, or be securely capped,

If above is good, you may want to consider cleaning the IAC valve with Carb Cleaner - be careful of any gaskets when you remove the valve, if damaged that will also introduce illegal air into the intake system,

Hope this helps,

Regards,
GottaCruise
 

·
Registered
2007 Kia Rio5, manual, roll up windows. 1996 Dodge Ram 1500 4x4, 5.9L V8
Joined
·
343 Posts
I'd check for vacuum leaks first thing.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
oops, my pic went missing, by the way, I'll check the vacuum first.

here's the pic of what Im asking if its the iac valve:
fulla_22_3.jpg
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7 (Edited by Moderator)
1996 kia sportage RPM hang rough idle

Good day! Ive already posted here before and tried to search similar problem like mine, but i cant find it. So I'll just ask again. My sportage is 2.0 gasoline 4x4. I am experiencing rought idle but every time i accelarate it, it runs smoothly, but when I stop giving gas, or try to shift, the rpm remains on 2000rpm+ and stays awail for like 5-10 seconds until it goes back to idle. So I tried to remove the iac valve plug and the symptoms went away and the car runs normally. Any ideas?

Additional info: before we experience these symptoms, the car broke and didnt start so we brought it to a mechanic and have it fixed. The car started but shows all of these symptoms

Any help would be much appreciated!
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
Is it supposed to run even I unplugged my iac valve? And there is still slight idle roughtness even i remove the iac. Sometimes the rpm goes down to 500rpm, but when i tried to turn on my aircon, idle goes up to 1000. Thanks for all the response. My car is really old and giving me headaches
 

·
Registered
Joined
·
2,216 Posts
Greetings aki_hero,

First, did you verify that the IAC valve ( the connector you pulled ) MATCHES the picture you posted? ( In other words, did you find the IAC valve on your motor ? )

Second, have you cleaned or REPLACED the IAC valve on your Sporty?

re: rough idle when disconnected - yes, that is to be expected, same happens here on the 2000 model ..

--
If it was my ride, I would make sure the air filter was clean/new, and clean or replace the IAC valve, the one on your vehicle seems to be giving you a headache.

*But would also be checking for illegal air leaks in the rubber duct work on the intake plenum, and checking for any vacuum leaks like previously posted,

Best wishes for a speedy repair.
GottaCruise
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
1.) yes, I pulled the connector of iac valve without removing the iac itself.
2.) the technician have it replaced before but I got mine from surplus shops. when I tried to put back the original IAC valve, It gets miuch worst. (rpm goes up beyond >2000 unlike previosly at 2000 only.
3.) I already replaced the air filter. But I cant find the illegal air leaks from rubber hose or any gaskets.

My car is running fine now without the iac valve connector plugged in. Im just worried that Im not getting the most efficient settings in my car.

Thank you for your very helful reply! more power!
 

·
Registered
Gen 1 Sportage
Joined
·
74 Posts
Sounds like they replaced it with a defective part, I had the same problem with my 01 Sportage, it would either idle high at 1500 to 2000rpm or constantly hunt up and down once it had reach normal temperature, I replaced the IAC valve and it is now fine.
 
1 - 14 of 14 Posts
Top