Kia Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I,m from the UK and have a 1.3 Kia Rio LX manual (68000 miles). A couple of months ago I was travelling down the motorway and could hear a loud ticking sound coming from the engine. I carried on driving and the sound then progressed to a really loud knocking, from it seems under the rocker cover. I took off the rocker cover and sump, and thouroughly cleaned all the old oil out, which was very lumpy, and replaced with fresh oil and filter. It seemed ok for a few weeks, but now when I start the car up, the noise is back and then seems to die out after about 5-6 minutes of driving.

I cannot seem to get a manual for the car anywhere, and wanted to know if anyone could point me in the right direction as to what this could be. Someone suggeted hydraulic lifters, but I had a mechanic look at it and he said that it didn,t appear to have lifters.

Any help would be most appreciated.

Thank you, Kev.
 

·
Registered
2008 Rio LX, 2007 Honda Shadow (Bike)
Joined
·
74 Posts
It's probably overhead cam which means no lifters. Lumpy oil is very bad. It sounds to me like you have restricted oil channels and the noise disappears after a few minutes because its taking that long to get the oil pressure up. I would find a good engine flush and follow the instructions on the bottle. You may have to do it more than once. Hopefully the engine isn't badly damaged. I've used Rislone here in the states. its not really a flush, more of a detergent additive. Works very well, but I don't if you have it there. You may need a genuine flushing product anyway.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi Wadmancpu.

Thank you for your reply.

I have flushed it like you suggested and the noise has pretty much gone, so I really appreciate your help.

Thanks again, Kev.
 

·
Registered
Cerato
Joined
·
692 Posts
Before the problem started:
-Did you change oil regularly? (lumpy oil/sludge)
-What brand & grade of oil?

You might like to try a thicker grade of oil now e.g. 5W-30
 

·
Registered
Joined
·
1 Posts
your oil pump pressure regulator valve is probably stuck wide open with trash in it . most of the time , foreign vehicles have easy access to them on the front of the engine . unscrew the plug , take out the spring , then pull the valve out . blow the trash out of the bore , clean any burrs that you can find with real fine sandpaper ,same on the valve ,then put it all back together and crank it up . if that don't make it quieter , then pull the oil pan ,and clean the sludge out of the oil pickup screen , and clean the pan good ,put it back on . that should help , unless your engine is just worn out .
 

·
Registered
Joined
·
1 Posts
Hi, I,m from the UK and have a 1.3 Kia Rio LX manual (68000 miles). A couple of months ago I was travelling down the motorway and could hear a loud ticking sound coming from the engine. I carried on driving and the sound then progressed to a really loud knocking, from it seems under the rocker cover. I took off the rocker cover and sump, and thouroughly cleaned all the old oil out, which was very lumpy, and replaced with fresh oil and filter. It seemed ok for a few weeks, but now when I start the car up, the noise is back and then seems to die out after about 5-6 minutes of driving.

I cannot seem to get a manual for the car anywhere, and wanted to know if anyone could point me in the right direction as to what this could be. Someone suggeted hydraulic lifters, but I had a mechanic look at it and he said that it didn,t appear to have lifters.

Any help would be most appreciated.

Thank you, Kev.

i have the same problem it is the oil pump and tappets
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,606 Posts
1 - 8 of 8 Posts
Top