Kia Forum banner

1 - 3 of 3 Posts

·
Registered
2000 Sportage EX 4x4 A/T, 2008 Harley Davidson Nightrain
Joined
·
184 Posts
Discussion Starter #1
Symptoms: A couple months after buying my Sportage, when starting the vehicle, the engine would turn over but not start. After a couple of starting attempts it would finally start. Originally it would only happen 1 out of every 20 or so starts but gradually got worse over time to where it happened a good 50% of the time. Shortly before I identified the problem the Sportage was starting to die shortly after starting once in awhile as well. The CEL would never light and no fault codes were ever generated.

RESOLUTION: After monitoring live data with a scan tool, cleaning up all ground points, doing vacuum testing, and inspecting the main & fuel pump relays, the prolem still persisted. Would have done fuel pressure tests too but the quick disconnect buttons were too mangeled to get off.

As a last ditch effort before doing something drastic, like cutting the fuel lines so I could do the pressure tests, I replaced the Main and Fuel Pump relays for S&Gs (even though they looked perfectly fine when I popped the covers off and inspected them).

Lo and behold she has started first try every time since (which was 2 weeks ago today).

The lesson learned here: If you don't know when or if they've ever been replaced, replace the relays anyway. Even if they still look like they are in good condition. I'd have saved myself a lot of going in circles and testing if I'd just replaced the relays as diagnostic step #1.

Also an FYI - The yellow replacement relays that RockAuto sells are not generic relays as I had thought. When mine came in the mail and I took them out of the box, I was plesantly suprised to see both a KIA and a Hyundai logo on the relays.
 

·
Registered
Joined
·
2,221 Posts
Hi Wolf,

Glad to hear the issue is resolved, and thanks for posting the FYI about the relays from RockAuto being KIA sourced / OEM - that helps.

Regards,
GottaCruise
 
1 - 3 of 3 Posts
Top