Kia Forum banner

1 - 6 of 6 Posts

·
Registered
2013 Sportage SX
Joined
·
32 Posts
Discussion Starter #1
Has anyone experianced any of electronic switch problems on your 2013 Sportages as stated in the news???
 

·
Registered
2011 AWD Sportage SX
Joined
·
926 Posts
Or our generation sportages 2011-2013.

But I do recall some members had a brake switch problem in their 3rd gen sportage.
 

·
Registered
2015 KIA Sorento LX V6 AWD / 2009 Kawasaki Ninja 650R
Joined
·
33 Posts
I had a brake switch problem on my 2011 Sportage. Issue was resolved by replacing the brake switch. It took them an hour to replace.
 

·
Registered
Joined
·
966 Posts
What were the symptoms of that brake switch problem? I'm seeing the 'swerve' and 'descent' lights on most of the time, and I've had it 'stick' in Park after starting the engine to drive away - like the brake interlock wasn't letting go. The last time was today after lunch, and I pressed the brake pedal harder to release the shifter. So I'm definitely suspecting the brake switch at this time.
 

·
Registered
Car: 2016 Sportage 2.0 Petrol (Aussie)...Bike: Suzuki GSF1250S Bandit with sidecar
Joined
·
268 Posts
I have one of the earliest new generation Sportage in Aust, it's actually a Oct 2010 Platinum (SX ?).

Have been having heaps of problems starting it over the past 3 months, had to pump the brake pedal a couple of times to start - but it wouldn't play up all the time. The dealer mechanics adjusted the Brake Switch a couple of times, and eventually replaced it about 4 weeks ago, not a problem since.
 
1 - 6 of 6 Posts
Top