Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Kia Sephia 2000
Joined
·
56 Posts
Discussion Starter #1
My Kia Sephia has rear window defogger switch/button right next to the hazard switch/button located above the radio in the center console. When I pressed the rear window switch/button, it does not click or stay in place when working. The hazard switch/button when pressed stays in place and working. I checked the rear window defogger fuse and the relay and both are good. I took the Kia to autozone and the guy said the rear window defogger switch/button, based on his experience, should hear a click on the switch/button when pressed and stayed to verify it is working. In this case, it does not. Is this rear defogger switch/button a wear and tear item and needs to be replace? (Kia Sephia is 18 years old). Anyone out there can relate to this issue and if so, any comments, feedback, advice is greatly appreciated. Thanks to all for reading this post.
 

·
Registered
Kia Sephia 2000
Joined
·
56 Posts
Discussion Starter #2
Update:

After starting up the Kia, I pressed the rear window defogger switch and there is no click as I expected. However, after pressing the rear window defogger switch, I noticed on the instrument cluster panel on the middle left side of the speedometer (in front of me) LIGHTED UP with the same icon/symbol on the rear window defogger switch!! This is the first time I noticed that. Is this normal without hearing a click when pressing the rear window defogger switch? Perhaps the rear window defogger switch corrected itself. Strange, indeed. Thanks to all for reading this post.
 
1 - 2 of 2 Posts
Top