Kia Forum banner

1 - 3 of 3 Posts

·
Registered
2003 kia sedona
Joined
·
1 Posts
Discussion Starter #1
i've just bought a kia sedona 2003 and the rear heating has been disconnected, can i get it to work? I've seen a you tube video that says you can replace the metal pipes with rubber ones, is that right?
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 08 Harley Nightrain
Joined
·
10,964 Posts
i've just bought a kia sedona 2003 and the rear heating has been disconnected, can i get it to work? I've seen a you tube video that says you can replace the metal pipes with rubber ones, is that right?
Using the below link, please add location and vehicle (year & model) to your User Account/Profile

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD


UPDATE: Vehicle Information


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 

·
Registered
Sedona '02
Joined
·
141 Posts
i've just bought a kia sedona 2003 and the rear heating has been disconnected, can i get it to work? I've seen a you tube video that says you can replace the metal pipes with rubber ones, is that right?
Yes, it was probably disconnected by the prior owner due to the leaks from rust.

The 1st gen Sedona has kind of weak front heater but the back heater is awesome. I know, it's kind of weird. However, the two pipes (inlet, outlet) get rusted easily.

You can use heater hoses (I highly recommend it) because they are cheaper to use, lasts a long time and do not rust like the factory oem pipe. Get two pairs worth of length and some for error.

My van pipe had multiple rust spots, leaked coolant on several occasions at different spots and almost fried my head gasket due to overheating.

You just have to raise the passenger side a bit to get access and (make sure which line is inlet and outlet - do not confuse it!!) connect the hoses to from the front to the back.

The usual rusts appear along the bottom portions where the pipe attaches to these metal hangers.

It's not a one single pipe for inlet and single pipe for outlet. There are several pipe parts and in between are these hose connectors.

There are two ways: you can do:
one long hose from front to back or attach a hose from the front to the middle hose section and middle to the rear hose section with those brass hose connector and hose clamps. You will know what I mean when you look at it. Make sure you get brass hose connector that is slightly larger than factory hose portion so that it does not leak. You don't want it to be loose. I had to get several pieces to make sure I got the right diameter. Same with the hose, make sure it's not loose. It should be relatively tight so that it does not leak.

Kia parts are all in metric and hoses from auto parts are all in SAE, so you have to figure this out for yourself. One size is kind loose fit and one size is tight fit. Better to go with tight fit.

My experience is that the front section are two pipes comes down diagonally downward from the engine then turns horizontal. Highly unlikely you have rust on that downward pipe. But make sure there is no rust. I connected my hose where the pipe angled horizontal.

On the rear, there are two pipes that come downward from the rear heater core. Then, it angles horizontal again. On this one, I had to connect the hoses where it was in the angled section because that's where the factory hose section is. You will see what I mean.

I tied the hoses along the original pipes are (I didn't remove them) with zip ties. I tied them at many sections so it is very secure. To this day, absolutely no issues and no leaks!

Try to avoid the hose from the exhaust pipe (it can get close to that sections) so that the heat does not melt the hose.
 
1 - 3 of 3 Posts
Top