Kia Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
My 04 Kia Rio rear defogger won't shut off, so far I have switched out the relay with the fan relay. Still won't shut off, I also tried another heater control panel. The light is always on and when I push the switch you can hear the relay cycle. The only way I can turn it off is to remove the fuse for the rear defog and the fuse for the mirror heater but the light still stays on. I'm thinking that I may have to wire a switch to each fuse slot.
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Being you have heated mirrors try unpluging the the rearefrost timer maybe it's bad just something to check. http://www.kiatechinfo.com/ for schematics. if you pull the relay does the light goes out with the defrost switch turned off? if it does check that timer also good luck with it. Reguards ronjohn
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
rear defog

If the timer is beside the relay I unplugged it and no difference, I also unplugged the relay and I am getting 12V on the red green and yellow wires. Being that the green wire is supposed to be the wire that goes to the defroster itself I wouldn't think I should be getting any power from it when the relay is removed. Thanks
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Sorry i don't have heated mirrors but my 02 book say's the timer is under the dash left side of the console behind you ventilation controlls. I don't know if your o4 is the same. I would agree with you if you pull the relay out the light should go out and 12VDC should not be present on the green wire look for a short somewhere in the wires hope this help some good luck. Reguard's Ronjohn
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Sorry it took so long to get back to fixing it. I just started taking out fuses, when I got to the rear wiper fuse the light went out. The rear wiper has never worked for me anyway, and when I put the fuses in for my mirror and defrogger they seem to work fine now. So it looks like when the weather gets warmer i'm going to have to take the panel off the door and just maybe I may find out why my wiper motor isn't working.
 
1 - 6 of 6 Posts
Top