Kia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,

First post here ! I have a 2006 5 speed LX that I have owned since new. I have never owned a car for 7 consecutive years, but this truck seems to be bullet proof. Going on 175K KMs (110K Miles) without any major issues. Always kept up the maintenance. I plan on passing this one onto my son. I'm not bad with a wrench, so from here on out, ill be doing most of the maintenance myself.

A recent issue that has come up is the rear wiper, which seems to be possessed. It simply does not shut off. For now I pulled the fuse. I am assuming it is an electrical issue, which is not my strong suit. Wondering if I can get some direction on where to start ? at the stalk, wiper motor ? any assistance would be appreciated

Thanks
 

·
Registered
05 Kia Sorento LX 4x4
Joined
·
280 Posts
The wipers on mine would get weird, where they would either not shut off (even with the truck off), or they would only work on "high" mode. I would jiggle the wiper switch and see if that helps. You may need to replace the stalk assembly. Oddly enough, mine stopped acting up when I replaced the alternator thinking the 13v while idling was a little low and causing problems. I can't say if it's because I had the battery out allowing the onboard computers to reset, or if there was some weird voltage issue, or if it was just a fluke that it's working properly now...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok thanks, great place to start. I appreciate the help from you both.
 

·
Registered
Joined
·
32 Posts
My 06 had the same issue. Only 3 years into warranty. Serviced under warranty by Williams KIA Traverse City. They replaced the wiring harness in the rear hatch and we have had no problems since.
 
1 - 5 of 5 Posts
Top