Kia Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 03 Kia Rio 4 door sedan. I am having problems when i am driving down the road all of a sudden it seems like the car is not getting any gas. I have replaced the air fow sensor. Plugs. Wires. Coil pack. Air filter. Fuel filter. What could be causing it to still run that way. It does not do it all the time.
 

·
Registered
Sportage LX AWD 2014, Forte LX+ 2014
Joined
·
678 Posts
Please stop throwing parts at it and throwing money away. Find a good mechanic who can properly diagnose the issue.
Have you had it scanned for codes?
 

·
Super Moderator
99 Kia Elan 1.8L, 17 Ford Edge Sport 2.7L V6, 15 Mustang 3.7L V6, 2013 BMW K1600 GTL
Joined
·
11,249 Posts
I have an 03 Kia Rio 4 door sedan. I am having problems when i am driving down the road all of a sudden it seems like the car is not getting any gas. I have replaced the air fow sensor. Plugs. Wires. Coil pack. Air filter. Fuel filter. What could be causing it to still run that way. It does not do it all the time.
Using the below link, please add location and vehicle (year & model) to your User Account/Profile

eg.
USA
2019 Sportage 2.7L V6 SX turbo AWD


UPDATE: Vehicle Information


Forum Rules


Tip: after updating your info, hit “like” on this post, and it will serve as a prompt to remove it.
 

·
Registered
2014 Hyundai Veloster Turbo / 2001 Kia Rio
Joined
·
292 Posts
MAF and fuel filter were the likely culprits but you replaced them (that was my experience when my car was stumbling). were they new or junkyard?

do you do the work on the car yourself? i'm curious if the fuel pump sock may be clogged... it's a 30 minute check as long as the bolts on top of the tank (removeable panel under the rear seat bottoms) come out easy.
 
  • Like
Reactions: Lou O.
1 - 4 of 4 Posts
Top