Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2002 Kia Rio (manual). Several months ago it started randomly losing power....sometimes my rpm's get caught around 2k...even if it gets going I have problems when I stop and try to go again...I don't always have a check engine light and every symptom is completely random.... (For example, I'd driven on a particular day 40 miles or so then it lost power out of nowhere...it would idle around 2k rpms or so in neutral but when I'd shift to first it would die but finally putted at a max of 10 miles an hour up a few miles of highway and then all the sudden drove fine again). I took it to AutoZone and it threw code 1166 (rich/lean fuel mixture/vacuum leak etc.)....I have replaced the fuel filter...I took it to a mechanic that changed out a leaky hose into my intake....and that seemed to fix the problem for a couple months until now it is acting up again randomly. I have taken it to another mechanic...waiting to hear back but he has already suggested that it may be my O2 sensor, my catalytic converter and an exhaust problem....yet I have read where people have fixed all this and still have the problem....I called a Kia dealership and the mechanic told me that a possible problem might be purge valves??? or my coil packs could have bad connectors??? He said it most likely wasn't the fuel pump since my problems are sporadic. This seems to be a common problem for Kias....I'm just confused and would like advice. I have no expertise at all about cars and I'm trying not to spend money I don't have...Please, any advice is greatly appreciated. Thanks! :)
 

·
Registered
2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Joined
·
1,023 Posts
Been there and done that megan. How many miles on your car? That darn p1166 got me also at 134000 miles. I also had some cylinder missfires p0300/p0304 which was related to it. It ended up being my second cat was blocked It would not even go up a little hill no power at all going down the hill it went great hence loss of power. I did plugs/wires/ filter/fuel pump with no success but My suggestion is to clean your IAC valve and disconnect the pipe between the 2 cat's and drive it to see if it helps when i did that my car came back to life. I busted out the 2nd cat and my car is still going strong. I hope this helps somewhat. Good Luck with it. Reguard's Ronjohn
 

·
Registered
2001 Kia Rio
Joined
·
2 Posts
RonJohn does bring up a very good point. Do you occasionally have the scent of rotten eggs around your car? That smell is a sign of a bad catalytic converter. The symptoms you describe can be caused by a clogged Catalytic converter.

Other questions are mileage on the vehicle and do you know if the Cats have been changed before? I have an 01 kia rio and had to replace the first catalytic converter, attached to the manifold, at 80,000 miles. I am not saying that is your problem, but it is a possibility.
 
1 - 3 of 3 Posts
Top