Kia Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hiyas... Im new to your site as well as KIAs in general... I recently bought a 98 Sephia... great car btw... but I noticed the passenger side running lights werent working, but the turn signals were... So i bought new bulbs and still had the same problem... the fuse panel cover in the engine compartment was missing when I got it... so I started pulling fuses till i found a blown one... replaced it and the lights worked... kewl problem solved... so I thought... the next day it was blown again... its popping fuses daily... so I'm guessing there is a short somewhere... dunno if anyone has had this problem or knows any partiular areas to look for it...

thanks
 

·
Premium Member
2015 Buick Verano "Leather Group", 2015 Kia Optima Hybrid
Joined
·
6,127 Posts
Originally posted by Nite Dragon@Feb 28 2005, 05:15 PM
Hiyas... Im new to your site as well as KIAs in general... I recently bought a 98 Sephia... great car btw... but I noticed the passenger side running lights werent working, but the turn signals were... So i bought new bulbs and still had the same problem... the fuse panel cover in the engine compartment was missing when I got it... so I started pulling fuses till i found a blown one... replaced it and the lights worked... kewl problem solved... so I thought... the next day it was blown again... its popping fuses daily... so I'm guessing there is a short somewhere... dunno if anyone has had this problem or knows any partiular areas to look for it...

thanks
wow that is gonna **** no pun intended!
anyways id start at the wiring that goes into light. actually come to think it isnt going to be to bad as just follow the wires from marker light to fuse panel. must be an open wire touching metal.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 
1 - 2 of 2 Posts
Top