Kia Forum banner

1 - 14 of 14 Posts

·
Registered
2016 KIA SORENTO LX TURBO
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys i have a 2016 lx turbo sorento with 123 000km. I send my truck at Kia last week and they told me i need a new engine cause the cam seized. I took my truck at my place and turn the cam and everything was fine ?!?!. I scan the truck and i have P2008-P0014-P0017. on the idle less than 1000rpm the truck shut off and doesnt turn properly. If its under 1000 the truck runs great... I think i need to change Cam sensor, crank sensor the ocv and cvvt assy... do you have any ideas about my problem ?
 

·
Super Moderator
99 Kia Elan 1.8L
Joined
·
11,753 Posts
Hi guys i have a 2016 lx turbo sorento with 123 000km. I send my truck at Kia last week and they told me i need a new engine cause the cam seized. I took my truck at my place and turn the cam and everything was fine ?!?!. I scan the truck and i have P2008-P0014-P0017. on the idle less than 1000rpm the truck shut off and doesnt turn properly. If its under 1000 the truck runs great... I think i need to change Cam sensor, crank sensor the ocv and cvvt assy... do you have any ideas about my problem ?
If you don't trust that Kia dealership find another one, or if its out of warranty find a reliable independent.

Less than / under 1000 rpm shuts off/ runs great ?????? - what is it?

What do you mean it "doesn't turn properly"?

With so many confusing comments, I don't know if it runs at all.
 
  • Like
Reactions: Lou O.

·
Registered
2016 KIA SORENTO LX TURBO
Joined
·
3 Posts
Discussion Starter · #3 ·
If you don't trust that Kia dealership find another one, or if its out of warranty find a reliable independent.

Less than / under 1000 rpm shuts off/ runs great ?????? - what is it?

What do you mean it "doesn't turn properly"?

With so many confusing comments, I don't know if it runs at all.
Sorry im french :LOL:
 

·
Registered
2016 KIA SORENTO LX TURBO
Joined
·
3 Posts
Discussion Starter · #4 ·
my truck is not on warranty anymore.. thats why im trying to find the problem on my own... The truck runs but it runs like a muscle car on the iddle..
if I raise the revolution to more than 1500 it runs great... less than that the truck turns off
 

·
Super Moderator
99 Kia Elan 1.8L
Joined
·
11,753 Posts
Do a forum search for intake runner problems.


 

·
Registered
2016 Sorento LX V6 AWD
Joined
·
653 Posts
The truck runs but it runs like a muscle car on the iddle..
if I raise the revolution to more than 1500 it runs great... less than that the truck turns off
That sounds like a timing issue. I would inspect the timing chain & tensioner if you can:


If that is all good, then I would guess it's a weird electrical issue with one of the components relating to those error codes you're seeing.
 

·
Registered
2016 Sorento SXL
Joined
·
1,830 Posts
Your P2008 code points to a faulty VCMA, which could indeed give the thing an idle akin to something with a full race cam.
The VCMA runner on these engines has been known to be a problem, and is definitely where you need to focus your attention. Search this forum for "VCMA" and I think you'll find a number of threads dealing with it.
 

·
Registered
2016 Sorento EX 2.0T AWD
Joined
·
1,589 Posts
Your P2008 code points to a faulty VCMA, which could indeed give the thing an idle akin to something with a full race cam.
The VCMA runner on these engines has been known to be a problem, and is definitely where you need to focus your attention. Search this forum for "VCMA" and I think you'll find a number of threads dealing with it.
The same issue just popped up this morning on my 16 EX Turbo: Engine Light on - and ODB code P2008. The car runs fine-ISH, except that if I step on the gas it chokes on it. I found the attached Service Bulletin that seems to apply to our models.
 

Attachments

·
Registered
2016 Sorento SXL
Joined
·
1,830 Posts
@josuet
Might help, might not. If the VCMA issue is a mechanical one (if you're hearing the noise that many people hear), the code change isn't going to fix it.

And there seems to be some confusion between P2008 and P200A. They can point to the same OR slightly different potential causes. If you have both together, that's one thing. If you have only the P200A or P2008, that's another.
 

·
Registered
2016 Sorento EX 2.0T AWD
Joined
·
1,589 Posts
@josuet
Might help, might not. If the VCMA issue is a mechanical one (if you're hearing the noise that many people hear), the code change isn't going to fix it.

And there seems to be some confusion between P2008 and P200A. They can point to the same OR slightly different potential causes. If you have both together, that's one thing. If you have only the P200A or P2008, that's another.
Got only the P2008. I haven't noticed any noise. Either way, the dealership said could only fix it free of charge if the car is under warranty. Not that I think that only Kia does it, but it is kind of unethical that even after knowing it will fail, they won't fix it proactively.
 

·
Registered
2016 Sorento EX 2.0T AWD
Joined
·
1,589 Posts
Update here. Later today, the engine service warning magically disappeared from my dashboard. Decided to poke around following the service manual. I reviewed the VCMA connector, and it all seems perfect.

Turned on the engine again, and there comes the dashboard warning up again. When I ran the ODB diagnostics, not one but two errors are now on: P2008 and P2017 (they seem related, though). The irony is the car performs as normal. Took it around the block for a test, and it runs perfectly. :LOL:

118407

To confirm if the VCMA is faulty (unsure if this is a valid test), I ran the engine over 3000 rpms (parked). According to the manual, the actuator should open at 2600 rpms, but nothing happened...maybe it only works when driving?

118408


Interestingly enough, when I turn off the engine, I can see the actuator going back and forth (that's something I have always heard but never knew what it was). So does that mean the VCMA is okay?

 

·
Registered
2016 Sorento SXL
Joined
·
1,830 Posts
Moving, but moving correctly?
It may be an intermittent failure, which is going to complicate life considerably.
Normally, you pull the intake and look to see if things are moving properly and not all carbon'd up. If the manifold and/or the control are full of crud, you won't get motion in a timely basis, nor perhaps even full range of motion.
 

·
Registered
2016 Sorento EX 2.0T AWD
Joined
·
1,589 Posts
Moving, but moving correctly?
It may be an intermittent failure, which is going to complicate life considerably.
Normally, you pull the intake and look to see if things are moving properly and not all carbon'd up. If the manifold and/or the control are full of crud, you won't get motion in a timely basis, nor perhaps even full range of motion.
Been trying to rule out the VCMA. Perhaps you can answer this. When the manual reads the Coil Resistance of the VCMA is 1~200 Ohms, to what pins is it referring to?

118442

118443


I tested the following combinations (engine was warm - outside temp 7 C):

Pins 1 and 3 ==> 6.5 Ohms
Pins 4 and 6 ==> 203 Ohms
Pins 5 and 6 ==> 158 Ohms
Pins 4 and 5 ==> 56 Ohms
 

·
Registered
2016 Sorento SXL
Joined
·
1,830 Posts
They're talking about the motor. So pins 1-3.
BTW, your 6.5 number looks about right.
 
1 - 14 of 14 Posts
Top