Kia Forum banner

1 - 7 of 7 Posts

·
Registered
2011 Sportage EX
Joined
·
53 Posts
Discussion Starter #1
Had the Sportage at the dealer today because it had been mis-firing from a cold start for the past while. It wouldn't stall but after the initial idle flare at start up, it would settle at 1500rpms and it could be heard mis-firing for a few seconds....sort of like it was stumbling if you know what I mean.

Anway, took it in for an appointment today and they pulled a P0300 code from it and from what I gather is a mutiple misfire code. It says reflashed as per bulletin so I'm thinking there may have been a tsb on it or something similar.

They also replaced one of the battery cable terminals and said there was a notice on those was well.

Anyone else have this yet?
 

·
Registered
2012 Sportage SX FWD
Joined
·
354 Posts
i brought mine in a while back and they took care of the battery cable terminal issue. Nothing about misfiring though. I asked them to replace a few plastic screw covers and rubber bumpers that had gone missing. No charge to replace.

No issues other than that.
 

·
Registered
2011 Sportage SX
Joined
·
82 Posts
Having the same issue but haven't taken mine in yet. Will do so soon and report back.
 

·
Registered
2011 Sportage EX
Joined
·
53 Posts
Discussion Starter #4
Well after the flash it's still there....maybe a little worse. It used to flare and drop down and stumble but now it sort of hitches for a second right after it starts, from a cold start still. I also notice that it seems to idle is lower with the AC on. It idles in drive just hair over 500 rpms which in my opinion is too low.
The flash changed the character of the engine but not for the better. It's my wife's so I don't drive it as much so I'm still trying to pinpoint what's up with it but it's def not the same.
 

·
Registered
Joined
·
554 Posts
Dunno. Maybe a spark plug issue, so I would check mine for physical damage and proper gapping. If it was the battery, I'd imagine the car wouldn't start, rather than start and stumble. My experience isn't in ECU fuel injection, but in small motors where I can adjust the carburetor for idle.

Updating firmware is a good first step, but a laptop won't replace a mechanic. Tell them the problem is still there, and watch that they physically check for problems. Wish I knew enough to help with that problem.
 

·
Registered
2011 Sportage EX
Joined
·
53 Posts
Discussion Starter #6
Yeah these types of problems are hard to track down. I was also thinking the plugs or coil packs not seated or something.
 

·
Registered
2011 Sportage EX 1.7cc Diesel - Manual transmission
Joined
·
154 Posts
Yeah these types of problems are hard to track down. I was also thinking the plugs or coil packs not seated or something.
OBD II Code P0300 : RepairPal

Hope you have already found the problem but if you did not yet, check this link.

You can find all sorts of definitions regarding obd2 codes on the net.

Keep us informed.
 
1 - 7 of 7 Posts
Top