Kia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2009 Borrego LX V6. About two months ago I started having issues with the idiling. I would come to a stop and the car would shutter, the check engine light came on and it would give the p0017 code, and sporatically shut off (at stops only). So far I have been told by two kia mechanics to change either the crank shaft position sensor or the cam shaft position sensor. Neither has worked the problem persists. Prior to the problem (when i bought the car used) I changed the oil for the 1st time and noticed the previous owner was using synthetic oil, so I changed to non-synthetic and that is when the problem started. Anybody have a similar problem? or a fix for this? I want to take it to the dealer but they are charging $90 just to diagnose the problem!!!!!!!! Any and all comments appreciated.
 

·
Registered
Borrego 2009
Joined
·
74 Posts
I assume you are past the 60k mile expiration of your warranty.

While I do not understand why 'dirty oil' appears at the top of this list that would appear to be an inexpensive place to start.

P0017

- Dirty Oil
- Engine mechanical problems
- Camshaft timing incorrectly set
- Faulty camshaft position sensor
- Faulty crankshaft position sensor
- Faulty actuator assembly

Other than the code the symptom of failing idle is normally associated with an idle air control valve. Perhaps that is what the last on the list is referring to.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Oil has been changed several times since the 1st time this issue has popped up, and I continue to get the code.
 
1 - 3 of 3 Posts
Top